axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Weiner" <kwei...@interactivebusiness.com>
Subject Re: Connection Refused Error
Date Thu, 21 Feb 2002 04:32:10 GMT
I tried to run AdminClient after putting the axis jars in another webapp
and got an error message. Why is AXIS not able to find the target
service? My command was this:

java org.apache.axis.client.AdminClient -l
http://localhost:8080/MyContext/servlet/AxisServlet deploy.wsdd

And the error message was this:

Processing file deploy.wsdd
AxisFault
  faultCode: ns1:Server.NoService
  faultString: The AXIS engine could not find a target service to
invoke!  targetService is http://xml.apache.org/axis/w
sdd/
  faultActor: null
  faultDetail:
        exceptionName: org.apache.axis.AxisFault
        stackTrace: The AXIS engine could not find a target service to
invoke!  targetService is http://xml.apache.org/a
xis/wsdd/
        at org.apache.axis.server.AxisServer.invoke(AxisServer.java:282)
        at
org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:485)



----- Original Message -----
From: "Jinghua Gu" <egu@cisco.com>
To: <axis-user@xml.apache.org>
Sent: Tuesday, February 19, 2002 11:12 AM
Subject: RE: Connection Refused Error


> Did you do the following command?
>
> java org.apache.axis.client.AdminClient
> -lhttp://localhost:8080/axis/services/AdminService deploy.wsdd
>
> where localhost is whatever your web server name.
>
> At 11:35 AM 2/19/2002 -0700, you wrote:
>
> >I am running WebSphere 3.5.2 and I have killed and restarted my
entire
> >machine, but I still get the 404 not found error below. It is just
not
> >there.
> >
> >
> >---
> >Thanks
> >
> >Mick Knutson
> >Discover Financial Services
> >Office: 801-902-4244
> >Fax: 801-902-4123
> >
> >
> >
> >
> >                     Jinghua
> > Gu
> >                     <egu@cisco.co        To:
axis-user@xml.apache.org
>  >
> >                     m>                   cc:
axis-user@xml.apache.org
>  >
> >                                          Subject:     RE: Connection
> > Refused Error
> >                     02/19/2002
>  >
> >                     11:37
> > AM
> >                     Please
>  >
> >                     respond
> > to
> >                     axis-user
>  >
> >
> >
> >
> >
> >
> >
> >
> >
> >You don't have to. Try to kill your browser and restart the tomcat.
> >Use exactly port number your server use(for example, 8080). It worked
for
> >me.
> >
> >Emily
> >
> >At 09:11 AM 2/19/2002 -0700, mickknutson@discoverfinancial.com wrote:
> >
> >      How do I install this AdminService? I find no reference to it
in the
> >      docs,
> >      except to deploy services.:
> >
> >
> >      C:
> >
>
>\WebSphere\AppServer\ICE\webapps\axis\WEB-INF\classes\samples\userguide
\example3>java
> >
> >
> >      org.apache.a
> >      xis.client.AdminClient -p80 deploy.wsdd
> >      Processing file deploy.wsdd
> >      AxisFault
> >        faultCode: http://xml.apache.org/axis/:HTTP
> >        faultString: Not Found
> >        faultActor: null
> >        faultDetail:
> >              null: return code:  404
> >      <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> >
> >      Not Found
> >
> >
> >      The requested URL /axis/services/AdminService was not found on
this
> >      server.
> >
> >
> >
> >      ---
> >      Thanks
> >
> >      Mick Knutson
> >      Discover Financial Services
> >      Office: 801-902-4244
> >      Fax: 801-902-4123
> >
> >
> >
> >                          Ramon Turnes
> >
> >                          <ramon.turnes-perez@        To:
> >      "'axis-user@xml.apache.org'"
> >                          hermes.si>
> >      <axis-user@xml.apache.org>
> >                                                      cc:
> >
> >                          02/18/2002 08:13 AM         Subject:
RE:
> >      Connection Refused Error
> >                          Please respond to
> >
> >                          axis-user
> >
> >
> >
> >
> >
> >
> >
> >      This usually means that you don't have the HTTP Server running
> >      on port 8080 which is the default. If you want to specify other
> >      port do the folllowing:
> >
> >      java org.apache.axis.client.AdminClient -p 80 deploy.wsdd
> >
> >      if your web server is running on port 80. Regards.
> >
> >      --------------------------------------
> >      Ramon Turnes Perez
> >      HERMES SoftLab, Litijska 47
> >      1000 Ljubljana, SLOVENIA
> >      Phone: +386 1 5865 638
> >      Fax:     +386 1 5865 270
> >      E-mail: ramon@hermes.si
> >      www.hermes-softlab.com
> >      --------------------------------------
> >
> >
> >      > -----Original Message-----
> >      > From: mickknutson@discoverfinancial.com
> >      > [mailto:mickknutson@discoverfinancial.com]
> >      > Sent: Monday, February 18, 2002 4:05 PM
> >      > To: axis-user@xml.apache.org
> >      > Cc: egu@cisco.com
> >      > Subject: Re: Connection Refused Error
> >      >
> >      >
> >      >
> >      > If you figure this one out, "please" let me know what you did
> >      > to fix it!
> >      > I have this issue and can't figure it out.
> >      >
> >      >
> >      > ---
> >      > Thanks
> >      >
> >      > Mick Knutson
> >      > Discover Financial Services
> >      > Office: 801-902-4244
> >      > Fax: 801-902-4123
> >      >
> >      >
> >      >
> >      >
> >      >                     Jinghua Gu
> >      >
> >      >                     <egu@cisco.co        To:
> >      > axis-user@xml.apache.org
> >      >                     m>                   cc:
> >      >
> >      >                                          Subject:
> >      > Connection Refused Error
> >      >                     02/16/2002
> >      >
> >      >                     03:09 PM
> >      >
> >      >                     Please
> >      >
> >      >                     respond to
> >      >
> >      >                     axis-user
> >      >
> >      >
> >      >
> >      >
> >      >
> >      >
> >      >
> >      >
> >      >
> >      > When I execute the following command in
samples/userguide/example3
> >      > directory from Unix,
> >      > I got the following error.
> >      >
> >      > Command: java org.apache.axis.client.AdminClient deploy.wsdd
> >      >
> >      > Error:
> >      >
> >      > Processing file deploy.wsdd
> >      > AxisFault
> >      >   faultCode: http://xml.apache.org/axis/:Server.userException
> >      >   faultString: java.net.ConnectException: Connection refused
> >      >   faultActor: null
> >      >   faultDetail:
> >      >         exceptionName: java.net.ConnectException
> >      >         stackTrace: java.net.ConnectException: Connection
refused
> >      >         at java.net.PlainSocketImpl.socketConnect(Native
Method)
> >      >         at
> >      > java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:312)
> >      >         at
> >      >
java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:125)
> >      >         at
> >      java.net.PlainSocketImpl.connect(PlainSocketImpl.java:112)
> >      >         at java.net.Socket.<init>(Socket.java:273)
> >      >         at java.net.Socket.<init>(Socket.java:100)
> >      >         at
> >      >
> >
org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:265)
> >      >         at
> >      >
> >
org.apache.axis.SimpleTargetedChain.invoke(SimpleTargetedChain.java:1
> >      > 04)
> >      >         at
> >      > org.apache.axis.client.AxisClient.invoke(AxisClient.java:178)
> >      >         at org.apache.axis.client.Call.invoke(Call.java:1254)
> >      >         at org.apache.axis.client.Call.invoke(Call.java:658)
> >      >         at
> >      >
org.apache.axis.client.AdminClient.process(AdminClient.java:323)
> >      >         at
> >      >
org.apache.axis.client.AdminClient.process(AdminClient.java:303)
> >      >         at
> >      >
org.apache.axis.client.AdminClient.process(AdminClient.java:310)
> >      >         at
> >      >
org.apache.axis.client.AdminClient.process(AdminClient.java:261)
> >      >         at
> >      > org.apache.axis.client.AdminClient.main(AdminClient.java:344)
> >      >
> >      > Thanks for your help!
> >      > Emily
> >      >
> >      >
> >      >
> >      >
> >      >
>


Mime
View raw message