axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanjay Krishnamurthi" <sanjay_krishnamur...@yahoo.com>
Subject Problem deploying services
Date Sun, 03 Feb 2002 19:20:03 GMT
While trying to deploy the examples in resin, I get the following exception.
It looks as if it is messing up parsing of what the target service is. Any
ideas/help would be appreciated.

   Sanjay

PS: The tcpMon output seems to indicate that right SOAP envelope is being
sent.


java org.apache.axis.client.AdminClient -lhttp://127.0.0.1:8080/axis/ser
vices/AdminServices deploy.wsdd
Processing file deploy.wsdd
AxisFault
  faultCode: ns1:Server.NoService
  faultString: The AXIS engine could not find a target service to invoke!
targe
tService is http://xml.apache.org/axis/wsdd/
  faultActor: null
  faultDetail:
        exceptionName: org.apache.axis.AxisFault
        stackTrace: The AXIS engine could not find a target service to
invoke!
targetService is http://xml.apache.org/axis/wsdd/
        at org.apache.axis.server.AxisServer.invoke(AxisServer.java:282)
        at
org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:48
5)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
        at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet
.java:82)
        at com.caucho.server.http.Invocation.service(Invocation.java:288)
        at
com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:1
32)
        at
com.caucho.server.http.ServletServer.serviceTop(ServletServer.java:93
7)
        at
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:213
)
        at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:
158)
        at com.caucho.server.TcpConnection.run(TcpConnection.java:140)
        at java.lang.Thread.run(Thread.java:484)
----- Original Message -----
From: "Patrick Roemer" <sangamon@t-online.de>
To: <axis-user@xml.apache.org>
Sent: Sunday, February 03, 2002 2:11 AM
Subject: Problem running examples


> Hello,
>
> just wanted to have a look at Axis, but I don't even get the
> examples right. I'm running this on Tomcat 4.0 (also 3.2) on
> Linux and have tried the last three nightly builds.
>
> Example 1 (which connects to the Apache server) gives me a
> SAXException: Bad enevelope namespace.
>
> With examples 2-5 the server-side code is executed and the
> correct result is returned from the method, but the client only
> receives null. No exception is thrown, it just receives plain
> null.
>
> If I replace the client-side Service/Call code with ServiceClient
> code, everything works fine (tried this with examples 2 and 3) -
> but ServiceClient is deprecated.
>
> Any hints?
>
> Regards,
> Patrick


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


Mime
View raw message