axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Williams,Ed" <EWILLI...@cerner.com>
Subject SOAPTypeMappingRegistry issue
Date Wed, 23 Jan 2002 18:05:11 GMT
I upgraded my code to the 01/17/02 interim drop from 12/06/01.  
I tried to use the ?WSDL from my browser to hit my service (that worked fine
before), only to find I received a NullPointerException.

After hours of print line insertion (and can someone tell me if you can
debug Axis in VCafe), I discovered that the SOAPTypeMappingRegistry was
returning a null for QName for the java.util.Calendar class.  It then gets
dereferenced with a .getLocalPart( ) call in the Types class.  
It must have worked before.

Does someone know how to resolve this?
Thank you,
Ed
CONFIDENTIALITY NOTICE

This message and any included attachments are from Cerner Corporation and are intended only
for the addressee. The information contained in this message is confidential and may constitute
inside or non-public information under international, federal, or state securities laws. Unauthorized
forwarding, printing, copying, distribution, or use of such information is strictly prohibited
and may be unlawful. If you are not the addressee, please promptly delete this message and
notify the sender of the delivery error by e-mail or you may call Cerner's corporate offices
in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.
-------------------------------------------


Mime
View raw message