axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Longshaw" <a...@blueskyline.com>
Subject Re: alpha 2 userguide/example3 problem
Date Thu, 13 Dec 2001 20:16:53 GMT
I think that this is the problem with the /services mapping
in alpha 2. Check out your web.xml and make sure that
the services mapping includes the wildcard like this one:


  <servlet-mapping>
    <servlet-name>AxisServlet</servlet-name>
    <url-pattern>/services/*</url-pattern>
  </servlet-mapping>

Cheers

Andy

----- Original Message -----
From: "John-Luc Bakker" <jlbakker@research.telcordia.com>
To: <axis-user@xml.apache.org>
Sent: Thursday, December 13, 2001 7:36 PM
Subject: alpha 2 userguide/example3 problem


> All,
>
> I may have a newbie question.  I am working through the
> userguide.  I have Tomcat 3.2.3.
>
> I successfully deployed example3 and ran the example3 client.
> Then I jumped to the WSDL section and tried to view the WSDL
> output through:
>
> %JAVA_HOME%\bin\java -cp
>
%XERCES_HOME\xerces.jar;%AXIS_HOME%\lib\axis.jar;%AXIS_HOME%\lib\log4j-core.jar;%AXIS_HOME
%\lib\wsdl4j.jar;;%AXIS_HOME%\lib\clutil.jar;.
> org.apache.axis.wsdl.Wsdl2java
> http://localhost:8080/axis/services/MyService?wsdl
>
> This failed:
> org.xml.sax.SAXParseException: File
> "http://localhost:8080/axis/services/MyService?wsdl" not found.
>         at
> org.apache.xerces.framework.XMLParser.reportError(XMLParser.java:1202)
>
>         at
>
org.apache.xerces.readers.DefaultEntityHandler.startReadingFromDocument(DefaultEntityHandl
er.java:512)
>
>         at
> org.apache.xerces.framework.XMLParser.parseSomeSetup(XMLParser.java:312)
>
>         at
> org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1080)
>         at
> org.apache.xerces.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:195)
>
>         at
> javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:184)
>
>         at
> org.apache.axis.utils.XMLUtils.newDocument(XMLUtils.java:196)
>         at org.apache.axis.wsdl.Emitter.emit(Emitter.java:133)
>         at
> org.apache.axis.wsdl.Wsdl2java.main(Wsdl2java.java:199)
> java.lang.NullPointerException
>         at com.ibm.wsdl.xml.WSDLReader.readWSDL(Unknown Source)
>         at org.apache.axis.wsdl.Emitter.emit(Emitter.java:151)
>         at org.apache.axis.wsdl.Emitter.emit(Emitter.java:134)
>         at
> org.apache.axis.wsdl.Wsdl2java.main(Wsdl2java.java:199)
> Error in parsing: null
>
> Tomcat echos:
> 2001-12-13 14:26:25 - Ctx( /axis ): 404 R( /axis +
> /services/MyService + null) null
>
> Then I had a look at my server.xml file and found that I during
> configuration of WSTK 2.4 I probably (had to) enter(ed) this
> line:
>
> <Context reloadable="true" path="/axis"
> docBase="c:\javasoft\wstk-2.4/axis/webapps/axis" debug="0"/>
>
> Idon't want to use WSTK; I want to play with AXIS.  However, my
> root for axis is "c:\javasoft\axis-1_0".  Should I change my
> docBase to get this working?  What should my docBase be to have a
> look at the wsdl for example3?
>
> I have been trying various things last nite and so far to no
> avail ...
>
> Thanks,
>
>     John-Luc
>
> --
> John-Luc Bakker     Telcordia Technologies
> tel: +1 973 829 5062   445 South Street
> gsm: +1 973 462 0538   Morristown, 07960 NJ
> fax: +1 973 829 2645   Yahoo & AIM messengers: jlbakker51
>
> **********************************************************
> Visit http://www.argreenhouse.com/ngnets for ETS enabled APIs
> Visit http://www.argreenhouse.com/JAINRefCode for JCC RI/TCK
> **********************************************************
>
>


Mime
View raw message