axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Cramer" <d...@fastcrypt.com>
Subject RE: Undeploying services and handlers
Date Thu, 06 Dec 2001 02:39:18 GMT
This same bug cost me a day. It appears that the wsdl code generator is
generating this.
 
Dave
-----Original Message-----
From: Glen Daniels [mailto:gdaniels@macromedia.com] 
Sent: Wednesday, December 05, 2001 12:35 PM
To: 'haddadc@cobia.net'
Cc: 'axis-user@xml.apache.org'; 'axis-dev@xml.apache.org'
Subject: RE: Undeploying services and handlers


(answer crossposted to axis-user and axis-dev - please restrict replies
to axis-dev)
 
Hi Chris!
 
The problem here is in the undeploy.wsdd file - the top-level element
should be <undeployment>, not <deployment>.  So the problem you're
seeing is a result of *deploying* "blank" handlers and services.  This
needs to get fixed so that we throw an appropriate fault.  But if you
change your element to <undeployment>, you should be able to undeploy
this just fine.
 
The same problem holds with your earlier example of undeploying just the
handler (i.e. you were actually deploying a blank copy of the handler,
not undeploying it), except that if you undeploy the handler and not the
service, the service will break.  Long run, we should be reference
counting this stuff so that you can't undeploy handlers that are being
used by other chains/services, but for now the solution should be
returning better error messages.
 
Thanks for using the package, and keep up the great feedback!
 
--Glen
-----Original Message-----
From: Chris Haddad [mailto:haddadc@cobia.net]
Sent: Wednesday, December 05, 2001 11:18 AM
To: axis-user@xml.apache.org
Subject: Undeploying services and handlers


 
Axis-User - 
 
I didn't see my postings coming through on axis-dev, so I'm
cross-posting this to the user's list.
  
When I run the following undeploy.wsdd file, the server-config.wsdd file
is nulled out to a zero size, and the 'list' command throws and
exception. 
 
Is there a bug in my undeploy file?
 
 
Here's the undeploy.wsdd used to attempt removal of the handler and the
service:
 
<deployment xmlns="http://xml.apache.org/axis/wsdd/">
 <service name="LogTestService"/>                    
 <handler name="track"/>                             
</deployment>                                        
 
 
Note, when I just undeploy the service, LogTestService, and don't
reference the handler, all is ok.  Although, there is still a vestigial
reference when performing the list command," <service
name="LogTestService"/>   "
 
 
/Chris
 
----------
Chris Haddad
Cobia Communications
mailto:chris@cobia.net
 

Mime
View raw message