axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Cramer" <d...@fastcrypt.com>
Subject RE: Authentication errors on stockquote sample
Date Tue, 13 Nov 2001 15:51:39 GMT
Glen,

That worked much better!, thanks
Now I take it I still have to move the users.lst, and perms.lst into my
webapp/WEB-INF dir?

Dave

-----Original Message-----
From: Glen Daniels [mailto:gdaniels@macromedia.com] 
Sent: November 13, 2001 10:48 AM
To: 'dave@fastcrypt.com'; 'axis-user@xml.apache.org'
Subject: RE: Authentication errors on stockquote sample



Hi Dave!

Try "-lhttp://localhost/webservices/services/AdminService" instead of
"-lhttp://localhost/webservices/servlet/AxisServlet".

The issue here is that because you're not telling the Axis engine which
service to invoke by using the URL, Axis tries to figure it out based on
the
namespace of the body element.  The old admin stuff used "AdminService"
as
its namespace, which resulted in calling (surprise!) the AdminService.
The
new stuff uses the WSDD namespace, which isn't registered as a service,
so
you should use the direct URL to the service (which is a much better
habit
to get into anyway).

--Glen

> -----Original Message-----
> From: Dave Cramer [mailto:dave@fastcrypt.com]
> Sent: Tuesday, November 13, 2001 10:33 AM
> To: axis-user@xml.apache.org
> Subject: RE: Authentication errors on stockquote sample
> 
> 
> Now I can't deploy the stock quote service?
> 
> java org.apache.axis.client.AdminClient -l
> http://localhost/webservices/servlet/AxisServlet deploy.wsdd $*
> Processing file: deploy.wsdd
> <ns1:Fault xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/">
>    <ns1:faultcode
> xmlns:ns4="http://xml.apache.org/axis/">ns4:Server.NoService</
> ns1:faultc
> ode>
>    <ns1:faultstring>The AXIS engine could not find a target service to
> invoke!  targetService is
> http://xml.apache.org/axis/wsdd/</ns1:faultstring>
>    </ns1:Fault>
> 
> Dave
> 
> -----Original Message-----
> From: Tim Johnson [mailto:Tim.Johnson@Sunquest.com] 
> Sent: November 13, 2001 10:08 AM
> To: 'axis-user@xml.apache.org'
> Subject: RE: Authentication errors on stockquote sample
> 
> 
> You will need the most recent nightly build as well.
> 
> -----Original Message-----
> From: Dave Cramer [mailto:dave@fastcrypt.com]
> Sent: Tuesday, November 13, 2001 8:01 AM
> To: axis-user@xml.apache.org
> Subject: RE: Authentication errors on stockquote sample
> 
> 
> 
> Omar,
> 
> I tried that, still no luck ;(
> 
> Dave
> -----Original Message-----
> From: Omar Benjelloun [mailto:omar.benjelloun@inria.fr] 
> Sent: November 13, 2001 9:37 AM
> To: axis-user@xml.apache.org; dave@fastcrypt.com
> Subject: Re: Authentication errors on stockquote sample
> 
> 
> Try copying the users.lst file from /samples/stock/
> to webapps/axis/web-inf
> 
> Cheers,
> 
> Omar
> 
> 
> ----- Original Message ----- 
> From: "Dave Cramer" <dave@fastcrypt.com>
> To: <axis-user@xml.apache.org>
> Sent: Tuesday, November 13, 2001 3:21 PM
> Subject: Authentication errors on stockquote sample
> 
> 
> > Hi
> > 
> > I just installed axis and am having trouble getting the stockquote
> > sample to run
> > 
> > 
> > java samples.stock.GetQuote
> > -lhttp://localhost/webservices/servlet/AxisServlet -uuser1 
> -wpass1 XXX
> > AxisFault
> >   faultCode: null
> >   faultString: User 'user1' not authenticated
> >   faultActor: null
> >   faultDetails: null
> > 
> > I have deployed the stockquote application and it succeeded. Where
> does
> > axis read the configuration from? There seem to be xml config files
> > everywhere?
> > 
> > Dave
> > 
> > 
> 
> 



Mime
View raw message