axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andre Vermeulen (ZA)" <Andre.Vermeu...@za.didata.com>
Subject RE: Newbie questions
Date Tue, 16 Oct 2001 07:23:57 GMT
Hi

I am getting at the same point as Andre - everything working fine I can see
the server is running everything in the classpath etc, but the user
authentication fails - this has to do with the default directory... of the
Servlet server not containing user.lst and perms.lst... But now the question
remains - what is the default directory of Tomcat 4.0 (Catalina) ?????

Glen Daniels previously replied on my question as such :

	"If you're using the latest versions of Axis (i.e. recent nightly
builds),
	this has been made consistent.  The files are expected to live in
WEB-INF/.
	Previously it was up to the servlet engine to decide - for JRun, it
was
	JRUN_HOME/servers/default/.  Putting it in WEB-INF as we do now
makes much
	more sense."

So ya - let me know if you got joy with this - will report back on any
success...

thanks

andre vermeulen

-----Original Message-----
From: Andre Juffer [mailto:ajuffer@sun3.oulu.fi]
Sent: Monday, October 15, 2001 8:10 AM
To: axis-user@xml.apache.org
Subject: Re: Newbie questions




Steven Lewis wrote:

> OK - I am having a lot of problems with the axis documentation
> It is unclear
> 1) Should axis run stand alone or with Tomcat?


Within a servlet container, such as tomcat.


> 2) How does axis determine its directory path - i.e. what directory should
> I launch it from?


Tomcat will take care of it, as long as you have put Axis in the webapp 
subdirectory.


> 3) Is there an archive of this list so I do not repeat questions already 
> answered


I was trying that myself. I could't find, so I guess it does not exist 
(yet).


> 
> I can get it to say
> SimpleAxisServer
> You've reached the SimpleAxisServer.


Which means the server is running ok.


> 
> when I run  SimpleAxisServer as the main but cannot get it to do 
> anything else.


Actually, I do have one or two problems with Axis myself. I got a few 
things to work after switching to Tomcat4.0 (Catalina). I got at least 
the deployment part working, but I cannot run the stock example (user 
authentication failure).

What exactly is not working for you?

> The Docs talk alot about icons I really do not see in the 
> distribution.
>  
> ==============================================================
> 
> LordJoe - Java Training and Consulting
> 
> http://www.LordJoe.com <http://www.lordjoe.com/>


-- 
Andre H. Juffer              | Phone: +358-8-553 1683
The Biocenter and            | Fax: +358-8-553-1141
     the Dep. of Biochemistry | Email: Andre.Juffer@oulu.fi
University of Oulu, Finland  | WWW: http://www.biochem.oulu.fi/Biocomputing/


**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************

Mime
View raw message