axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wenbiao Han" <wenbiao....@ulticom.com>
Subject Re: Axis installation problem
Date Mon, 15 Oct 2001 20:15:02 GMT

----- Original Message -----
From: "Don Smith" <dev4net@hotmail.com>
To: <Andre.Juffer@oulu.fi>; <axis-user@xml.apache.org>
Sent: Friday, October 12, 2001 12:17 PM
Subject: Re: Axis installation problem


> Andre,
>
> I too have had a lot of problems getting everything all set up.  I believe
> what finally got me past this problem was adding WEB-INF/classes to the
> tomcat CLASSPATH.  If that doesn't work for you, let me know - I'll
probably
> have other suggestions.
>
> -= Don =-
>
>
> >From: Andre Juffer <ajuffer@sun3.oulu.fi>
> >Reply-To: Andre.Juffer@oulu.fi
> >To: axis-user@xml.apache.org
> >Subject: Axis installation problem
> >Date: Fri, 12 Oct 2001 18:47:26 +0300
> >MIME-Version: 1.0
> >Received: from [64.125.133.20] by hotmail.com (3.2) with ESMTP id
> >MHotMailBD905D4C00864004325A407D85140F540; Fri, 12 Oct 2001
08:54:53 -0700
> >Received: (qmail 36258 invoked by uid 500); 12 Oct 2001 15:43:40 -0000
> >Received: (qmail 36092 invoked from network); 12 Oct 2001 15:43:35 -0000
> >From axis-user-return-79-dev4net Fri, 12 Oct 2001 08:55:27 -0700
> >Mailing-List: contact axis-user-help@xml.apache.org; run by ezmlm
> >Precedence: bulk
> >list-help: <mailto:axis-user-help@xml.apache.org>
> >list-unsubscribe: <mailto:axis-user-unsubscribe@xml.apache.org>
> >list-post: <mailto:axis-user@xml.apache.org>
> >Delivered-To: mailing list axis-user@xml.apache.org
> >Message-ID: <3BC7108E.5050700@cc.oulu.fi>
> >Organization: The University of Oulu
> >User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2)
> >Gecko/20010726 Netscape6/6.1
> >X-Accept-Language: en-us
> >X-Spam-Rating: daedalus.apache.org 1.6.2 0/1000/N
> >
> >Hi All,
> >
> >I am experiencing some problems with AXIS/SOAP. The setup I have is:
> >Apache1.3, Tomcat3.2.2, Java1.3. I have followed the installation
> >instructions, but unfortunately I do not get things running as they
> >should. Below you will find the error message I get, when I try one of
> >the examples.
> >
> >It seems that the server is running (else I would not get a message as
> >the one below, right?). I don't think it has something to do with
> >Tomcart (since I am running Cocoon2 as well, without problems). So, I
> >suppose there is some Axis problem (read: I do something wrong). I
> >should mention that I am very new to SOAP/AXIS so I am still in the
> >learning phase.
> >
> >I have been trying to locate an archive for axis-user somewhere,
> >assuming that somebody else may have had a similar problem, but I could
> >not find it. Does it already exist? I hope that one of you can give me a
> >clue what to look for. Clearly, it cannot the find the service. Is it
> >because the server is not running after all? If so, how to find out if
> >the server is running? E.g. is there a logfile?
> >
> >Thank you,
> >Andre
> >
> >
> >---------
> >juffer@ajuffer-dsl:~/axis-1_0/samples/stock> ./testit.sh
> >Deploy everything first
> >Processing file: deploy.xml
> ><ns1:Fault xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/">
> >    <ns1:faultcode
> >xmlns:ns4="http://xml.apache.org/axis/">ns4:Server.NoService</ns1:f
> >aultcode>
> >    <ns1:faultstring>The Axis engine couldn't find a target service to
> >invoke! targetS
> >ervice is AdminService</ns1:faultstring>
> >   </ns1:Fault>
> >
> >These next 2 should work...
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >The rest of these should fail... (nicely of course)
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >This should work but print debug info on the client and server
> >Exception in thread "main" java.lang.NoClassDefFoundError:
> >samples/stock/GetQuote
> >Processing file: undeploy.xml
> ><ns1:Fault xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/">
> >    <ns1:faultcode
> >xmlns:ns4="http://xml.apache.org/axis/">ns4:Server.NoService</ns1:f
> >aultcode>
> >    <ns1:faultstring>The Axis engine couldn't find a target service to
> >invoke! targetS
> >ervice is AdminService</ns1:faultstring>
> >   </ns1:Fault>
> >----
> >
> >--
> >Andre H. Juffer              | Phone: +358-8-553 1683
> >The Biocenter and            | Fax: +358-8-553-1141
> >     the Dep. of Biochemistry | Email: Andre.Juffer@oulu.fi
> >University of Oulu, Finland  | WWW:
> >http://www.biochem.oulu.fi/Biocomputing/
> >
>
>
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
>
>


Mime
View raw message