axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From andrew.bu...@webgain.com
Subject problems using Wsdl2java (again), in IBM code
Date Thu, 27 Sep 2001 23:21:05 GMT
I am trying to test the Wsdl2java utility, but I've had no success. Details
follow.
I presume something is incorrect in my configuration. I would appreciate any
assistance. Thanks in advance.

Andrew Burke
Webgain, Inc.
Portland, Oregon USA
503-276-6301

-----------------------------------
My command line is:
  D:\axis1\atest>java org.apache.axis.wsdl.Wsdl2java -v glossary2.wsdl

The results is this:
  Parsing XML File: glossary2.wsdl
  WSDLException (at /definitions/binding/soap:binding): 
   faultCode=CONFIGURATION_ERROR: No ExtensionDeserializer found to
deserialize
   a 'http://schemas.xmlsoap.org/wsdl/soap:binding' element in the context
of a 'javax.wsdl.Binding'.:
        at javax.wsdl.extensions.ExtensionRegistry.queryDeserializer(Unknown
Source)
        at com.ibm.wsdl.xml.WSDLReader.parseExtensibilityElement(Unknown
Source)
        at com.ibm.wsdl.xml.WSDLReader.parseBinding(Unknown Source)
        at com.ibm.wsdl.xml.WSDLReader.parseDefinitions(Unknown Source)
        at com.ibm.wsdl.xml.WSDLReader.readWSDL(Unknown Source)
        at org.apache.axis.wsdl.Emitter.emit(Emitter.java:151)
        at org.apache.axis.wsdl.Emitter.emit(Emitter.java:134)
        at org.apache.axis.wsdl.Wsdl2java.main(Wsdl2java.java:199)

Environment: Windows 2k, Java 1.3.1
(some manual reformatting of below text has been done...)

classpath=;d:\axis1\xalan\bin\xerces.jar;d:\axis1\xalan\bin\xalan.jar; \
 
d:\axis1\xalan\bin\xalan2jdoc.jar;d:\axis1\xalan\bin\xml.jar;d:\javas\j2ee\l
ib\j2ee.jar; \
 
d:\axis1\lib\axis.jar;d:\axis1\lib\clutil.jar;d:\axis1\lib\log4j-core.jar;d:
\axis1\lib\wsdl4j.jar;.

(all jar files listed above exist, and I've got the latest Axis and Xalan
releases)

Clearly, I run smack into a problem in the IBM code (which I don't have the
source to).
Is there something missing from my configuration, or am I missing a jar from
my classpath,
or is this retribution for all the mean things I did as a kid?...

again, thanks in advance,
andrew burke
webgain, inc


Mime
View raw message