axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sourav dalal (JIRA)" <>
Subject [jira] [Commented] (AXIS2-5154) java.lang.NoSuchMethodError:;Ljava/lang/String;)J
Date Thu, 21 Mar 2019 18:09:00 GMT


sourav dalal commented on AXIS2-5154:


I am trying to upgrade my project from Axis 2 1.5.3 to Axis 2 1.7.9. I have removed all the
jars from Axis 2 1.5.3 version & replaced them with 1.7.9; but it is throwing the above
errorĀ java.lang.NoSuchMethodError:;Ljava/lang/String;)I

This method is being called from model classes generated in Axis 1.5.3. I can see the method
in class path but it throws the same error. Above mentioned 3 jars are present from Axis 2
1.7.9. Any suggestion/guidance will be helpful


Sourav Dalal

> java.lang.NoSuchMethodError:;Ljava/lang/String;)J
> --------------------------------------------------------------------------------------------------------------------------------
>                 Key: AXIS2-5154
>                 URL:
>             Project: Axis2
>          Issue Type: Bug
>          Components: adb
>    Affects Versions: 1.5.5
>         Environment: UNIX, JAVA
>            Reporter: axis2user
>            Priority: Major
>              Labels: maven
>   Original Estimate: 468h
>  Remaining Estimate: 468h
> I downloaded axis2-1.5.5-bin from Internet and generated my stub using wsdl2java command.

> Everything is working fine when i am manually running the application using "java" command,
sending a request and getting a response from Server.
> When I am running the same application using Jar file using "java -jar AAA.jar "command,
getting the following exception.
> Exception in thread "Thread-0" java.lang.NoSuchMethodError:;Ljava/lang/String;)J
>         at org.apache.axis2.axis2userguide.QuantumUAStub$ErrorCode_type1.setErrorCode_type0(
>         at org.apache.axis2.axis2userguide.QuantumUAStub$ErrorCode_type1$Factory.parse(
>         at org.apache.axis2.axis2userguide.QuantumUAStub$GetSubscriberResponse$Factory.parse(
>         at org.apache.axis2.axis2userguide.QuantumUAStub.fromOM(
>         at org.apache.axis2.axis2userguide.QuantumUAStub.getSubscriber(
>         at org.apache.axis2.axis2userguide.SOExecutionThread.getCustomer(
>         at
>         at
> Tried lot of things like changing the jar files, but getting the same exception every
time. This method is there in the jar file, still throwing this error.
> My Manifest file is pasted below which contains all the jar files being used.
> Manifest-Version: 1.0
> Created-By: 1.5.0_05 (Sun Microsystems Inc.)
> Class-path: axis2-1.5.jar axis2-kernel-1.5.5.jar commons-logging-1.1.1.jar geronimo-stax-api_1.0_spec-1.0.1.jar
wstx-asl-3.2.9.jar wsdl4j-1.6.2.jar XmlSchema-1.4.3.jar axiom-impl-1.2.11.jar axiom-dom-1.2.11.jar
axiom-api-1.2.11.jar neethi-2.0.5.jar commons-httpclient-3.1.jar activation-1.1.jar commons-fileupload-1.2.jar
woden-api-1.0M8.jar woden-impl-dom-1.0M8.jar httpcore-4.0.jar axis2-adb-1.5.jar commons-codec-1.3.jar
mail-1.4.jar axis2-transport-local-1.5.jar axis2-transport-http-1.5.jar
> Main-Class: org.apache.axis2.axis2userguide.AAA_Broadhop
> Please help me to resolve this issue. The funtionality is working perfectly fine, only
above problem comes when I try to run the code after creating the jar file.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message