axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Artur Linhart (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (AXIS2-5946) IDEA Plugin cannot be installed into IDEA environment
Date Sat, 12 Jan 2019 18:23:00 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16741353#comment-16741353
] 

Artur Linhart edited comment on AXIS2-5946 at 1/12/19 6:22 PM:
---------------------------------------------------------------

Hm, this can be. In IDEA there is universal web service generator for the java classes, which
allows also the generation of the code with the axis2 tools from the binary distribution (wsdl2code)
, so possibly the plugin is not so important. But it still does not allow a lot of configurations
of the generation process...

But in some cases you still need to generate the java files once and then edit them (test,
or modification of some specific functionality like checking the http headers etc.).

I just wanted to test it, if it won't be better than the Axis2 "native" IDEA plugin - so,
possibly this piece of software should be discontinued, it there is nothing, what would bring
it more, than current built-in Axis2 support in IDEA, I guess nobody uses 10 years old IDEA
anymore.


was (Author: goodwin):
Hm, this can be. In IDEA there is universal web service generator for the java classes, which
allows also the generation of the code with the axis2 tools from the binary distribution (wsdl2code)
, so possibly the plugin is not so important. But it still does not allow a lot of configurations
of the generation process...

But in some cases you still need to generate the java files once and then edit them (test,
or modification of some specific functionality like checking the http headers etc.).

I just wanted to test, what could be better in the Axis2 "native" IDEA plugin - so, possibly
this piece of software should be discontinued, it there is nothing, what would bring it more,
than current built-in Axis2 support in IDEA, I guess nobody uses 10 years old IDEA anymore.

> IDEA Plugin cannot be installed into IDEA environment
> -----------------------------------------------------
>
>                 Key: AXIS2-5946
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5946
>             Project: Axis2
>          Issue Type: Bug
>          Components: ide plugins
>    Affects Versions: 1.7.9
>         Environment: IDEA 2018.3.3, Java 8
>            Reporter: Artur Linhart
>            Priority: Critical
>
> The downloaded ZIP with Axis2 Plugin cannot be installed into IDEA 2018.3.3
> After download and installation attempt from disk (File/Settings/Plugins/Install from
Disk) there comes an error "Fail to load plugin descriptor from file axis2-idea-plugin-1.7.9.zip"
and nothing is installed.
> This makes the plugin completely unusable



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message