axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nadir amra (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TRANSPORTS-57) Appel WebService SOAP RPGLE gelé
Date Thu, 15 Feb 2018 17:23:00 GMT

    [ https://issues.apache.org/jira/browse/TRANSPORTS-57?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16365973#comment-16365973
] 

nadir amra commented on TRANSPORTS-57:
--------------------------------------

Wrong forum.  This forum should not be used to report problems.  Open a PMR.

In any case, load the latest PTFs and recreate stubs and try again:

SI66622                                  V7R1M0 
SI66850                                  V7R1M0 

SI66623                                  V7R2M0 
SI66849                                  V7R2M0 

SI66624                                  V7R3M0 
SI66848                                  V7R3M0

 

> Appel WebService SOAP RPGLE gelé
> --------------------------------
>
>                 Key: TRANSPORTS-57
>                 URL: https://issues.apache.org/jira/browse/TRANSPORTS-57
>             Project: Axis2 Transports
>          Issue Type: Bug
>         Environment: Le serveur Apache AXIS2 tourne sur un IBM i (anciennement AS400).
> Le client est un programme RPGLE qui utilise un STUB RPGLE créer à partir d'un WSDL.
> Le serveur distant hébergeant le WS est un serveur IIS.
> La ligne internet entre le client et le serveur distant peut être dégradé et parfois
subir des coupures momentanées.
>            Reporter: SDOUGA Mehdi
>            Priority: Major
>
> Bonjour,
> J'ai un soucis lorsque j'utilise Apache AXIS pour appeller des WS à partir de STUB,
ces derniers restent parfois figé en attente de réception de données. Ce blocage est rare
(environ 5% des appels) mais problématique.
> *Problème*
> J'ai créer un programme utilisant un STUB générer par un script IBM à partir d'un
WSDL fournie par notre prestataire. La plupart du temps, le programme s'exécute correctement,
il envoi des données au serveur de WS distant et reçoit une réponse avant de se terminer.

> Mais il arrive que mon programme "bloque" au moment de l'appel du WS, à ce moment là
selon la pile d'appel du programme il semble être en attente de réception de donné du serveur
distant. Malgrès le fait que l'on ai rajouté un TIMEOUT lors de la génération du STUB
le problème persiste et cela est très gênant car il peut rester plusieurs jours à attendre
sans erreur ni aucun messages dans la JOBLOG.
> *Informations complémentaires*
> Commande de génération du STUB : /QIBM/ProdData/OS/WebServices/V1/client/bin/wsdl2rpg.sh
-t60 -o"$2" -s"/QSYS.LIB/$3.LIB/$4.SRVPGM" -p"$5" "$1" -ma"$6"
> Dernières instructions de la pile d'appel du programme :
> QAXIS10X    QSYSDIR   readBytes_18SoapBinInputSt...
> QAXIS10HT  QSYSDIR   getBytes__13HTTPTransportFP...
> QAXIS10HT  QSYSDIR   readHTTPHeader__13HTTPTrans...
> QAXIS10HC  QSYSDIR   readBytes__11HTTPChannelFPc...
> QSOSRV1     QSYS        recv
> Merci d'avance.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message