axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kelly Besmar (JIRA)" <axis-...@ws.apache.org>
Subject [jira] [Commented] (AXIS-2915) Axis1.4 with java 1.7 is having TLS Protocal issue
Date Mon, 22 May 2017 18:46:04 GMT

    [ https://issues.apache.org/jira/browse/AXIS-2915?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16019997#comment-16019997
] 

Kelly Besmar commented on AXIS-2915:
------------------------------------

Any resolution on this? Is this a JAVA issue and not an AXIS issue?  

> Axis1.4 with java 1.7 is having TLS Protocal issue
> --------------------------------------------------
>
>                 Key: AXIS-2915
>                 URL: https://issues.apache.org/jira/browse/AXIS-2915
>             Project: Axis
>          Issue Type: New Feature
>    Affects Versions: 1.4
>         Environment: unix,windows
>            Reporter: madhusudhakar reddy
>
> we are using axis 1.4 with java 7 in our host server(weblogic10)
> we have a client who stopped supporting SSL protocol version lesser than TLS1.2.
> But in java 1.7 ,TLS 1.2 is not the default protocol, hence the requests to the client(who
doesn't support lesser than TLS 1.2) are going with TLS1, causing the communication issue.
> can we have an option or configuration to set the default TLS protocol  while creating
the Socket/SocketConnectionFactory?
> Please let me know if there is any option/configuration to resolve this or if it was
fixed with later versions
> Thanks,
> Madhusudhakar Reddy Tippaluru
> madhusudhakar@gmail,com
> mb:8886800771



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message