axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krithika Raghunath (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AXIS2-5837) Curl command not working with newly generated stubs using axis2 1.7.4
Date Tue, 07 Feb 2017 05:06:41 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-5837?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Krithika Raghunath updated AXIS2-5837:
--------------------------------------
    Description: 
I am trying to upgrade axis2 from version 1.6.2. to 1.7.4.
As part of this, I have regenerated stubs using a WSDL and XSD files.

With these generated stubs, the business logic is getting deployed as expected in tomcat.
But with curl command, I am getting an error as so:

curl -m 10 --data @request.xml -H "Content-Type:text/xml;Charset='UTF-8'" http://<username>:<password>@localhost:8080/NE3S/1.0/<Service>

<faultstring>The endpoint reference (EPR) for the Operation not found is http://localhost:8080/NE3S/1.0/<Service>
and the WSA Action = null. If this EPR was previously reachable, please contact the server
administrator.</faultstring>

Previously generated stubs with the same WSDL and XSD with axis2 1.6.2 are working fine. Kindly
let me know what is the issue.

  was:
I am trying to upgrade axis2 from version 1.6.2. to 1.7.4.
As part of this, I have regenerated stubs using a WSDL and XSD files.

With these generated stubs, the business logic is getting deployed as expected in tomcat.
But with curl command, I am getting an error as so:

curl -m 10 --data @request.xml -H "Content-Type:text/xml;Charset='UTF-8'" http://<username>:<password>@localhost:8080/NE3S/1.0/<Service>

<faultstring>The endpoint reference (EPR) for the Operation not found is http://localhost:8080/NE3S/1.0/<Service>
and the WSA Action = null. If this EPR was previously reachable, please contact the server
administrator.</faultstring>

Previously generated stubs with the same WSDL and XSD with axis2 1.6.2 are working fine. Kindly
let me know what is the issue?


> Curl command not working with newly generated stubs using axis2 1.7.4 
> ----------------------------------------------------------------------
>
>                 Key: AXIS2-5837
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5837
>             Project: Axis2
>          Issue Type: Bug
>    Affects Versions: 1.7.4
>         Environment: OpenJDK 8u31, Axis2 1.7.4, Red Hat Enterprise Linux Server release
6.4 (Santiago), Tomcat 8.0.39
>            Reporter: Krithika Raghunath
>            Priority: Blocker
>
> I am trying to upgrade axis2 from version 1.6.2. to 1.7.4.
> As part of this, I have regenerated stubs using a WSDL and XSD files.
> With these generated stubs, the business logic is getting deployed as expected in tomcat.
But with curl command, I am getting an error as so:
> curl -m 10 --data @request.xml -H "Content-Type:text/xml;Charset='UTF-8'" http://<username>:<password>@localhost:8080/NE3S/1.0/<Service>
> <faultstring>The endpoint reference (EPR) for the Operation not found is http://localhost:8080/NE3S/1.0/<Service>
and the WSA Action = null. If this EPR was previously reachable, please contact the server
administrator.</faultstring>
> Previously generated stubs with the same WSDL and XSD with axis2 1.6.2 are working fine.
Kindly let me know what is the issue.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message