axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Kraus (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5806) Axis2 SNI (Server Name Indicator) support
Date Mon, 12 Sep 2016 13:44:20 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5806?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15484157#comment-15484157
] 

Gerald Kraus commented on AXIS2-5806:
-------------------------------------

When running Axis2 1.7.3 with HttpClient 4.3.2 the problem is that Axis2 1.7.3 is using
{code:java}
    AbstractHttpClient
{code} 
in
{code:java}
    org.apache.axis2.transport.http.impl.httpclient4.HTTPSenderImpl
{code} 
which is deprecated since HTTPClient 4.3.

I've modified this class in a quick and dirty way (replace AbstractHttpClient with CloseableHttpClient).
Now SNI headers (Extension server_name) are sent correctly.





> Axis2 SNI (Server Name Indicator) support
> -----------------------------------------
>
>                 Key: AXIS2-5806
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5806
>             Project: Axis2
>          Issue Type: Bug
>          Components: transports
>    Affects Versions: 1.7.3
>         Environment: Axis2 1.7.3
> Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
> httpclient-4.3.2
> apache-tomcat-7.0.67
> openSUSE Leap 42.1 (x86_64)
>            Reporter: Gerald Kraus
>              Labels: axis2, sni
>
> According to https://issues.apache.org/jira/browse/HTTPCLIENT-1119 HTTPClient 4.3.2 supports
SNI (Server Name Indicator).
> According to http://axis.apache.org/axis2/java/core/release-notes/1.7.0.html Axis2 1.7.3
should work with HTTPClient 4.3.X
> Axis is configured to use HTTPClient via axis2.xml:
> <transportSender name="https" class="org.apache.axis2.transport.http.impl.httpclient4.HTTPClient4TransportSender">
>         <parameter name="PROTOCOL">HTTP/1.1</parameter>
>         <parameter name="Transfer-Encoding">chunked</parameter>
>         <parameter name="SO_TIMEOUT">180000</parameter>
>         <parameter name="CONNECTION_TIMEOUT">180000</parameter>
> </transportSender>
> If i turn on SSL debugging (-Djavax.net.debug=all) i can't see "Extension server_name"
in debug output >> SNI info is not sent via HTTPS.
> When using httpclient-4.3.2 without Axis2 SNI info is sent via HTTPS.
> Is there missing support for SNI in Axis2 1.7.3?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message