axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <>
Subject [jira] [Resolved] (AXIS2-5701) changeType() not functioning after Ant build and Deployment
Date Sat, 28 May 2016 21:44:12 GMT


Andreas Veithen resolved AXIS2-5701.
    Resolution: Incomplete

> changeType() not functioning after Ant build and Deployment
> -----------------------------------------------------------
>                 Key: AXIS2-5701
>                 URL:
>             Project: Axis2
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.6.2
>         Environment: Windows Server 2008 R2, Apache Tomcat 8.0, Eclipse Luna
>            Reporter: Schuyler Williams
>              Labels: Eclipse, XmlSchemaType, ant, build, xmlbeans
> I built a top down web service in Eclipse using Axis2 and XmlBeans. When I test the service
in Eclipse it works fine, but when I do an Ant build and deploy the service in Tomcat on a
remote server I have problems. Basically there is a point where I create a new XmlObject based
on an autogenerated schema. I then use changetype() to change it to the correct schema type.
Then I cast it to the correct object type which is extending XmlObject. This works in Eclipse,
but after full deployment I get a ClassCastException because changeType() doesn't change the
XmlObject to the correct Object type.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message