axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AXIS2-5760) Service class must have public as access modifier
Date Tue, 19 Apr 2016 08:39:25 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-5760?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Veithen updated AXIS2-5760:
-----------------------------------
    Priority: Minor  (was: Blocker)

> Service class must have public as access modifier
> -------------------------------------------------
>
>                 Key: AXIS2-5760
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5760
>             Project: Axis2
>          Issue Type: Bug
>          Components: kernel
>    Affects Versions: 1.7.0
>         Environment: Windows 7, Java 7_u80 and Java 8_u66
> axis2 version 1.7.1
>            Reporter: Pascal Kn├╝ppel
>            Priority: Minor
>             Fix For: 1.7.2
>
>
> I am acutally not really sure if this is a Bug or wrong configuration but as wished here
as an issue.
> Hi I currently got the problem that I am not able to access my service.
> I patched it from axis 1.5.1 to axis 1.7.1. The old version still works
> fine but if I deploy the upgraded version and try to access it via a
> simple testclient I get the following error message, that the server
> does not even log with logging level on debug:
> {code:xml}
>     <?xml version="1.0" encoding="UTF-8"?>
>     <soapenv:Envelope
>     xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>         <soapenv:Header/>
>         <soapenv:Body>
>             <soapenv:Fault>
>                 <faultcode>soapenv:Server</faultcode>
>                 <faultstring>Service class
>     de.fiverx.steuerberater.ws.v1.Service must have public as access
>     Modifier</faultstring>
>                 <detail/>
>             </soapenv:Fault>
>         </soapenv:Body>
>     </soapenv:Envelope>
> {code}
> my Service class looks as follows:
> {code:title=Service.java|borderStyle=solid}
>     package de.fiverx.steuerberater.ws.v1;
>     public final class Service implements
>     SteuerberaterOnlineServiceSkeletonInterface {
>             public
>     de.fiverx.steuerberater.gfi_bremen.v1.LadeAbrechnungsDatenErgebnis
>     ladeAbrechnungsDaten(
>     de.fiverx.steuerberater.gfi_bremen.v1.LadeAbrechnungsDatenAnfrage
>     ladeAbrechnungsDatenAnfrage0) {
>                     return new LadeAbrechnungsDatenErgebnis();
>             }
>     }
> {code}
> and at last my services.xml
> {code:xml}
>     <?xml version="1.0" encoding="UTF-8"?>
>     <!-- This file was auto-generated from WSDL -->
>     <!-- by the Apache Axis2 version: 1.5.1  Built on : Oct 19, 2009
>     (10:59:00 EDT) -->
>     <serviceGroup>
>         <service name="SteuerberaterOnlineService">
>             <messageReceivers>
>                 <messageReceiver mep="http://www.w3.org/ns/wsdl/in-out"
>     class="de.fiverx.steuerberater.ws.v1.SteuerberaterOnlineServiceMessageReceiverInOut"/>
>             </messageReceivers>
>             <parameter
>     name="ServiceClass">de.fiverx.steuerberater.ws.v1.Service</parameter>
>             <parameter name="useOriginalwsdl">false</parameter>
>             <parameter name="modifyUserWSDLPortAddress">true</parameter>
>             <operation name="ladeAbrechnungsDaten"
>     mep="http://www.w3.org/ns/wsdl/in-out"
>     namespace="http://ws.gfi-bremen.de/online/services/SteuerberaterOnline/v1">
>     <actionMapping>http://ws.gfi-bremen.de/online/services/SteuerberaterOnline/v1#ladeAbrechnungsDaten</actionMapping>
>     <outputActionMapping>http://ws.gfi-bremen.de/online/services/SteuerberaterOnline/v1/SteuerberaterOnlinePortType/ladeAbrechnungsDatenResponse</outputActionMapping>
>             </operation>
>         </service>
>     </serviceGroup>
> {code}
> removing the final keyword does not help either.
> Any suggestions what is going wrong here?
> P.s.: I am currently updating 7 projects to this axis2 version and only 1 project does
not have this error. The configuration though is pretty much the same. That's why I do not
understand what the mistake might be.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message