axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5701) changeType() not functioning after Ant build and Deployment
Date Mon, 18 Apr 2016 22:48:25 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5701?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15246728#comment-15246728
] 

Andreas Veithen commented on AXIS2-5701:
----------------------------------------

Can you provide a test case?

> changeType() not functioning after Ant build and Deployment
> -----------------------------------------------------------
>
>                 Key: AXIS2-5701
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5701
>             Project: Axis2
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.6.2
>         Environment: Windows Server 2008 R2, Apache Tomcat 8.0, Eclipse Luna
>            Reporter: Schuyler Williams
>              Labels: Eclipse, XmlSchemaType, ant, build, xmlbeans
>
> I built a top down web service in Eclipse using Axis2 and XmlBeans. When I test the service
in Eclipse it works fine, but when I do an Ant build and deploy the service in Tomcat on a
remote server I have problems. Basically there is a point where I create a new XmlObject based
on an autogenerated schema. I then use changetype() to change it to the correct schema type.
Then I cast it to the correct object type which is extending XmlObject. This works in Eclipse,
but after full deployment I get a ClassCastException because changeType() doesn't change the
XmlObject to the correct Object type.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message