axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5736) How to prevent xml from decoding
Date Thu, 10 Dec 2015 08:01:11 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15050280#comment-15050280
] 

Andreas Veithen commented on AXIS2-5736:
----------------------------------------

Character references are decoded during XML parsing. That is true for Axis2 and JAX-WS, and
that is the way it should be.

> How to prevent xml from decoding
> --------------------------------
>
>                 Key: AXIS2-5736
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5736
>             Project: Axis2
>          Issue Type: Bug
>          Components: transports
>    Affects Versions: 1.6.3
>            Reporter: Lulseged Zerfu
>
> Hi
> I am using AXIS2 1.6.3 and my XML is decoded when I receive it.
> As the "&" character is not allowed in XML, I have to encode it when I send a soap
request to AXIS.
> Instead of sending {{<display-name>axis&axis</display-name>}} I have
to send encoded like:
> {noformat}
> <display-name>axis&amp;axis</display-name>
> {noformat}
> But somewhere in AXIS it is decoded back to "&".
> How can I make sure that my XML in the soap request arrives intact to my application?
> Is there any configuration that I have to apply or this is not AXIS issue?
> BR
> Lulseged Zerfu



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message