axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Schmidt (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AXIS2-5628) Axis OSGi Bundle doesn't provide AxisServices with original WSDL
Date Wed, 01 Oct 2014 13:43:33 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-5628?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andy Schmidt updated AXIS2-5628:
--------------------------------
    Attachment: AXIS2-5628_2.patch

> Axis OSGi Bundle doesn't provide AxisServices with original WSDL
> ----------------------------------------------------------------
>
>                 Key: AXIS2-5628
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5628
>             Project: Axis2
>          Issue Type: Bug
>    Affects Versions: 1.6.2
>            Reporter: Andy Schmidt
>            Priority: Critical
>             Fix For: 1.7.0, 1.6.3
>
>         Attachments: AXIS2-5628.patch, AXIS2-5628_2.patch, OSGiBundleBasedWSDLLocator.java,
OSGiBundleFileBasedURIResolver.java, ServiceRegistry.java, org.apache.axis2.osgi_patch.7z
>
>
> I am using the Axis2 OSGi Bundle in version 1.6.2. Currently its not possible to provide
AxisService with original WSDL files.
> So if i set the useOriginalwsdl parameter to 'true' like
> <service name="...">
>     <parameter name="useOriginalwsdl">true</parameter>
> </service>
> I get the error message
> <error><description>Unable to generate WSDL 1.1 for this service</description><reason>If
you wish Axis2 to automatically generate the WSDL 1.1, then please set useOriginalwsdl as
false in your services.xml</reason></error>



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message