axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Janke (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AXIS2-5637) Non-compiling wsdl2java XMLBeans code - nonexistent org.apache.axiom.om.OMElement.Factory
Date Fri, 14 Mar 2014 20:16:44 GMT
Andrew Janke created AXIS2-5637:
-----------------------------------

             Summary: Non-compiling wsdl2java XMLBeans code - nonexistent org.apache.axiom.om.OMElement.Factory

                 Key: AXIS2-5637
                 URL: https://issues.apache.org/jira/browse/AXIS2-5637
             Project: Axis2
          Issue Type: Bug
          Components: databinding, wsdl
    Affects Versions: 1.6.2
         Environment: Windows 7 Pro x64 SP1 with all Windows Updates applied as of 2014-03-13.

Running on MacBook Pro under Boot Camp.
Oracle Java JDK 1.7.0_51
Rampart 1.6.2 installed in to my AXIS2_HOME installation
            Reporter: Andrew Janke


The wsdl2java tool is generating non-compiling Java code for me when I use it on the WSDL
file from https://misapi.ercot.com/2007-08/Nodal/eEDS/EWS/?WSDL. The "ant" call errors out
complaining about missing identifiers. 

This WSDL is a bit odd in that it uses generic XML documents as payloads for most of its calls,
and includes and embedded (at least partial) schema for them.

To reproduce:

Download the WSDL file from https://misapi.ercot.com/2007-08/Nodal/eEDS/EWS/?WSD and save
as ERCOT-nodal-ews_downloaded.wsdl.
mkdir artifacts
cd artifacts
wsdl2java -uri ..\ERCOT-nodal-ews_downloaded.wsdl -p com.example.ercotnodal -d xmlbeans -s
mkdir resources
ant > build-output.txt


I get an error output that looks like the following.

[javac] C:\temp\artifacts\src\com\example\ercotnodal\NodalServiceStub.java:659: error: cannot
find symbol
    [javac]             return org.apache.axiom.om.OMElement.Factory.parse(
    [javac]                                                 ^
    [javac]   symbol:   variable Factory
    [javac]   location: interface OMElement
	

BUILD FAILED
C:\temp\artifacts\build.xml:50: Compile failed; see the compiler error output for details.


This error only happens with the "-d xmlbeans" databinding. The "-d adb" and "-d jaxbri" generate
code that compiles for the same WSDL.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message