axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "T. Allen" <...@verizon.net>
Subject Re: Regex problems with XMLBeans
Date Mon, 17 Feb 2014 16:09:54 GMT
Robert,

Thanks very much for this information.

T


On 2/14/2014 6:34 PM, robertlazarski . wrote:
> On Fri, Feb 14, 2014 at 8:14 PM, T. Allen<bif@verizon.net>  wrote:
>> I did not receive any replies about this problem but was able to get past
>> it.  Changing the regex from:
>> <xsd:pattern value="^(NA|UN).*"/>
>>
>> to:
>> <xsd:pattern value="(NA|UN).*"/>
>>
>> fixed the problem.  It seems XML Beans does not interpret the leading ^
>> symbol correctly.  Is this by design or should I create a JIRA?
>>
>> Thanks,
>> T
>>
> Glad to you found the problem. While I have used xmlbeans with axis2,
> I never used regex like that with it and didn't have any advice.
>
> Looking here though indicates that this is by design:
>
> http://www.w3.org/TR/xmlschema-0/#regexAppendix
>
> "the expression language does not contain the metacharacters ^ and $,
> although ^ is used to express exception, e.g. [^0-9]x" .
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message