axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rashmin Shinde (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5604) Configured the axis2 in existing web application but not able to access the Web service.
Date Tue, 01 Oct 2013 10:10:31 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5604?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13782785#comment-13782785
] 

Rashmin Shinde commented on AXIS2-5604:
---------------------------------------

Thank you for your time, Kishanthan. 

The issue has already been resolved. Actually, everything was in place and running fine locally
on my machine, howerver, it was failling when i tried to move my application war file on uat
environment. And  before moving the war file i was recreating the wsdl using the UAT url and
redeploy the war file. This is the reason it was failling to recognise the WS request.

Solution: I build the project on my local environment and move the same war file to uat. Did
not made any change to war or jar and it worked.

Thank you once again.


> Configured the axis2 in existing web application but not able to access the Web service.
> ----------------------------------------------------------------------------------------
>
>                 Key: AXIS2-5604
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5604
>             Project: Axis2
>          Issue Type: Bug
>    Affects Versions: 1.6.2
>         Environment: Unix, Apache tomcat 5.5, Java 5
>            Reporter: Rashmin Shinde
>            Priority: Blocker
>
> Team,
> I have configured the new Axis2 WebService into my existing application. It got deployed
successfully and application is also up. However, when I try to access the wsdl via a client
or by pasting the end poitn url into IE it gives me a message as pasted below.
> The webpage cannot be found 
>  HTTP 404  
>   More information : This error (HTTP 404 Not Found) means that Internet Explorer was
able to connect to the website, but the page you wanted was not found.
> The same war file is running perfectly fine in local environment but it fails to locate
service in out UAT environment.
> When the war file is exploded as below:
> webapps2 /appName/WEB-INF/services/DocumentDelivery/META-INF/services.xml
> services.xml:
> <serviceGroup>
>     <service name="DocumentDeliveryService" scope="application" >
>         <Description>
>             Service to downloads the documents for classification.
>         </Description>
>         <schema schemaNamespace="http://xxx.xxxx.xxxxx.com"/>
>         <messageReceivers>
>                 <messageReceiver mep="http://www.w3.org/2004/08/wsdl/in-out"
>                                  class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"/>
>         </messageReceivers>
>         <parameter name="ServiceClass" locked="xsd:false">com.xxxxx.xxxxx.xxxxx.DocumentDelivery</parameter>
>             <operation name="serviceName">
>                 <messageReceiver class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"/>
>             </operation>
>             <operation name="downloadDocument">
>                 <messageReceiver class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"/>
>             </operation>
>     </service>
> </serviceGroup>
> Please sugeest if any configuration changes that I need do to access the WS.
> Thanking you in anticipation.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message