axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "prasad jeewantha (JIRA)" <j...@apache.org>
Subject [jira] [Created] (RAMPART-404) Use a bouncy castle newer version instead of bcprov-jdk15-140
Date Wed, 24 Jul 2013 05:39:48 GMT
prasad jeewantha created RAMPART-404:
----------------------------------------

             Summary: Use a bouncy castle newer version instead of bcprov-jdk15-140
                 Key: RAMPART-404
                 URL: https://issues.apache.org/jira/browse/RAMPART-404
             Project: Rampart
          Issue Type: Improvement
            Reporter: prasad jeewantha
            Priority: Critical


Hi folks,

I was developing a security feature for Apache Synapse (OCSP/CRL) which uses bouncy castle
bcprov-jdk15on-146.jar which is a newer version. The version which Rampart uses is way too
old and is incompatible with newer versions. Due to this incompatibility I couldn't use the
newer version since JVM picks the older version from the libraries resulting what is knows
as Jar hell. In the discussion I had at Bouncycaslte mailing list, the developers suggested
Rampart to use a newer version since bcprov-jdk15-140 is out dated. 

Thanks,
Jeewantha.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message