axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sven Strohschein (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5379) The third URL parameter can not be processed (REST web service with WSDL 2.0)
Date Sat, 27 Apr 2013 07:00:20 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5379?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13643569#comment-13643569
] 

Sven Strohschein commented on AXIS2-5379:
-----------------------------------------

Hi,

Thank you for the continuous and constructive support. :-) Could you please also post your
WSDL file?

I just tried to apply your configurations of the services.xml (with the working variant with
only two parameters to check if the changes are generally working). I see differences in the
message receiver configurations and I have some more configurations like the "operation" element
and more parameters. When I only apply the message receivers instead of using the generated
InOut receiver, Axis2 throws "wrong number of arguments":
{code:xml}
<soapenv:Reason xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope">
	<soapenv:Text xml:lang="en-US">wrong number of arguments</soapenv:Text>
</soapenv:Reason>
{code}
When I also try to remove all the parameters and the "operation" element which you doesn't
have within your services.xml, the whole service isn't found anymore: "The service cannot
be found for the endpoint reference (EPR) /services/XYAccessWebServiceREST/getAccess?account=demo&pin=1234".

Here is my services.xml which is working with two, but not three parameters:
{code:xml}
<?xml version="1.0" encoding="UTF-8"?>
<!-- This file was auto-generated from WSDL -->
<!-- by the Apache Axis2 version: 1.6.2  Built on : Apr 17, 2012 (05:33:49 IST) -->
<serviceGroup>
    <service name="XYAccessWebServiceREST">
        <messageReceivers>
            <messageReceiver mep="http://www.w3.org/ns/wsdl/in-out" class="xy.access.webservice.XYAccessWebServiceRESTMessageReceiverInOut"/>
        </messageReceivers>
        <parameter name="ServiceClass">xy.access.webservice.XYAccessWebServiceREST</parameter>
        <parameter name="useOriginalwsdl">true</parameter>
        <parameter name="modifyUserWSDLPortAddress">true</parameter>
        <operation name="getAccess" mep="http://www.w3.org/ns/wsdl/in-out" namespace="xy-ws-rest">
            <actionMapping>\"\"</actionMapping>
            <outputActionMapping>urn:accessResponse</outputActionMapping>
        </operation>
    </service>
</serviceGroup>
{code}
                
> The third URL parameter can not be processed (REST web service with WSDL 2.0)
> -----------------------------------------------------------------------------
>
>                 Key: AXIS2-5379
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5379
>             Project: Axis2
>          Issue Type: Bug
>          Components: wsdl
>    Affects Versions: 1.6.2
>            Reporter: Sven Strohschein
>            Priority: Blocker
>         Attachments: hello-rest.wsdl, HelloWebServiceREST.java, RESTSample_1.0.0.aar,
services.xml
>
>
> I have developed a simple "hello world" REST web service with WSDL 2.0 and Axis2.
> There are three URL parameters defined, but the third URL parameter can not be processed
(ADBException regarding unexpected element). The first two parameters are processed correctly.
> I could not get an answer via the axis2 mailing list regarding this problem ( http://mail-archives.apache.org/mod_mbox/axis-java-user/201207.mbox/%3C500F0ADF.1050108%40gmx.de%3E
), could not find any examples, tutorials or documentation for a REST web service with WSDL
2.0 and more than two parameters.
> The full example code, wsdl, etc. is attached to this issue.
> URL calls
> http://localhost:8080/services/helloWebServiceREST/getHello?input=test -> working
> http://localhost:8080/services/helloWebServiceREST/getHello?input=test&second=test2
-> working
> http://localhost:8080/services/helloWebServiceREST/getHello?input=test&second=test2&third=test3
-> not working ("org.apache.axis2.databinding.ADBException: Unexpected subelement second")
> http://localhost:8080/services/helloWebServiceREST/getHello?input=test&third=test3
-> not working ("org.apache.axis2.databinding.ADBException: Unexpected subelement input")
> Request element
> <xsd:element name="hellorequest">
>   <xsd:complexType>
>     <xsd:sequence>
>       <xsd:element minOccurs="0" name="input" nillable="true" type="xsd:string"/>
>       <xsd:element minOccurs="0" name="second" nillable="true" type="xsd:string"/>
>       <xsd:element minOccurs="0" name="third" nillable="true" type="xsd:string"/>
>     </xsd:sequence>
>   </xsd:complexType>
> </xsd:element>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message