axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From satyapriya sahoo <sahoo.satyapr...@gmail.com>
Subject Re: How to add soapactor to AXISFAULT using java
Date Mon, 01 Apr 2013 15:38:56 GMT
Any feed back on it


On Mon, Apr 1, 2013 at 9:08 PM, satyapriya sahoo <sahoo.satyapriya@gmail.com
> wrote:

> Any feed back on it....................
>
>
> On Wed, Mar 20, 2013 at 1:00 PM, satyapriya sahoo <
> sahoo.satyapriya@gmail.com> wrote:
>
>> I am using axis2 and I want to throw axis fault (SOAP1.1), my fault xml
>> should be
>>
>>
>>  <?xml version="1.0" encoding="UTF-8"?>
>> <soapenv:Envelope xmlns:soapenv="
>> http://schemas.xmlsoap.org/soap/envelope/">
>>     <soapenv:Body>
>>         <soapenv:Fault xmlns:SOAP-ENV="
>> http://schemas.xmlsoap.org/soap/envelope/">
>>             <faultcode>SOAP-ENV:Server</faultcode>
>>             <faultstring>Unable to process the request because EMPID is
>> null.</faultstring>
>>             <faultactor>EMP-XML</faultactor>
>>             <detail >
>>                 <faultDetails>EMPID not populated</faultDetails>
>>             </detail>
>>         </soapenv:Fault>
>>     </soapenv:Body>
>> </soapenv:Envelope>
>>
>>
>>
>> Presently I am throwing the bellow exception,
>>
>>
>> *String str = "<faultDetails>EMPID not populated</faultDetails>";*
>> * *
>>
>> *OMElement faultDetail= AXIOMUtil.stringToOM(str);*
>> * *
>>
>> *throw new AxisFault(new QName(null,"Server","SOAP-ENV"), " Unable to
>> process the request because EMPID is null."," EMP-XML ",null, faultDetail
>> );*
>> * *
>>
>>
>> But while getting the error message in client code, in xml *<faultactor>*
>> *EMP-XML**</faultactor> *code is not coming,
>>
>>
>> *How to add the faultactor tag to my soap fault xml?*
>>
>
>

Mime
View raw message