axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ladislav Lencucha (JIRA)" <>
Subject [jira] [Commented] (AXIS2-5440) Tomcat using 100% CPU when application/json (JSONMessageFormatter) is used
Date Thu, 18 Oct 2012 15:44:05 GMT


Ladislav Lencucha commented on AXIS2-5440:

In some configurations (json vs jsonp) I also receive a strange error (JSON containing XML):
{"Fault":{"$":"<\/faultcode>No JSON message received through HTTP GET or POST<\/faultstring><\/soapenv:Fault>"}}

> Tomcat using 100% CPU when application/json (JSONMessageFormatter) is used
> --------------------------------------------------------------------------
>                 Key: AXIS2-5440
>                 URL:
>             Project: Axis2
>          Issue Type: Bug
>    Affects Versions: 1.6.2
>         Environment: Apache Tomcat/6.0.35	1.6.0_21-b07	Sun Microsystems Inc.	Windows
7	6.1	x86
>            Reporter: Ladislav Lencucha
>              Labels: JSON
>         Attachments: axis2.xml, ConsoleServer.aar,
> I am trying to connect to my webservice using GET + JSON.
> I've added JSONMessageFormatter and JSONOMBuilder for "application/json" content type.
> When I try to call the webservice using jQuery and HTTP GET with content type "application/xml"
I receive the response almost immediately (note that there is a jQuery error raised afterwards,
because Xml cannot be parsed as JSON).
> When I try to call the webservice using the same code but with content type "application/json"
there is no response and Tomcat uses 100% of CPU (there are also some messages in log file
mentioning that it should have ended).
> See my aar file and jQuery example attached. Also see my axis2.xml configuration.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message