axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sagara Gunathunga (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AXIS2-5321) Eclipse plugins broken in trunk
Date Tue, 15 May 2012 15:45:44 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-5321?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sagara Gunathunga  resolved AXIS2-5321.
---------------------------------------

    Resolution: Fixed
      Assignee: Sagara Gunathunga 

Fixed in r1338696.
                
> Eclipse plugins broken in trunk 
> --------------------------------
>
>                 Key: AXIS2-5321
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5321
>             Project: Axis2
>          Issue Type: Bug
>          Components: Tools
>    Affects Versions: nightly
>         Environment: Ubuntu 12.04 , Eclipse  Indigo/ Eclipse Helios 
>            Reporter: Sagara Gunathunga 
>            Assignee: Sagara Gunathunga 
>            Priority: Critical
>             Fix For: 1.7.0
>
>
> For both Axis2 Eclipse code generation and service archive plugins broken in current
trunk. Installing them manually I got following exception.
> org.osgi.framework.BundleException: The bundle "org.apache.axis2.eclipse.codegen.plugin_1.7.0.SNAPSHOT
[798]" could not be resolved. Reason: Missing Constraint: Import-Package: org.relaxng.datatype;
version="0.0.0"
>     at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
>     at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
>     at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
>     at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
>     at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
>     at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:333)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>     at java.lang.reflect.Method.invoke(Method.java:616)
>     at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:209)
>     at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
>     at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
>     at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
>     at java.lang.Thread.run(Thread.java:679)
> We can exclude "org.relaxng.datatype" from plug-in POM file but I think it's better to
find root cause for this issue. I tested 1.6.2 plug-ins without any issue.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message