axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammo van Lessen <tvanles...@gmail.com>
Subject Re: NPE in LocalTransportReceiver.processMessage()
Date Thu, 09 Feb 2012 16:59:52 GMT
Bump!

https://issues.apache.org/jira/browse/AXIS2-3219 still exists. All I'm
asking for is to re-open it. It can be verified and fixed later.

On Fri, Oct 21, 2011 at 20:02, Yashwanth Rajaram -X (yrajaram - ZENSAR
TECHNOLOGIES INC at Cisco) <yrajaram@cisco.com> wrote:
> Hi Tammo,
>
> I had faced some issue when using local transport and later I figured
> out how to use it. Maybe it is all about how to use it. I had posted my
> findings which you can see in the archived mail thread here:
> http://mail-archives.apache.org/mod_mbox/axis-java-user/201107.mbox/%3C9
> C3B47F84C2F814DA02F301C0158838A03FD64C3@xmb-sjc-222.amer.cisco.com%3E
>
> Here is a gist:
> I tried to use org.apache.axis2.integration.LocalTestCase.java (which is
> used by Axis for Unit Tests). I bundled this along with my code and
> called getClient(serviceName, OperationName) method on it. But when
> executing my code it was unable to resolve the service...  I had
> accessed the service in this format "local://services/MyService"...
>
> Later I figured out that the following call does not work as desired
> (which is the  cause for not finding the service), so I changed it as I
> have shown below:
>
> ConfigurationContext ctx =
> ConfigurationContextFactory.createConfigurationContextFromFileSystem(nul
> l, null);
>
> So I had to supply the parameters (see below) to get this to work as
> desired:
>
> ConfigurationContext ctx =
> ConfigurationContextFactory.createConfigurationContextFromFileSystem(Rep
> ositoryPath, AxisXML);
>
>
> thanks,
> --
> Yashwanth
>
> -----Original Message-----
> From: Tammo van Lessen [mailto:tvanlessen@gmail.com]
> Sent: Friday, October 21, 2011 2:04 AM
> To: java-dev@axis.apache.org
> Subject: NPE in LocalTransportReceiver.processMessage()
>
> Hi devs,
>
> can someone please review and re-open AXIS2-3219? I added detailed
> informations about the problem and two suggestions for potential fixes.
> It can be fixed by a single parameter passing change. I'm happy to
> provide a patch as well, but would like know which solution better fix
> into Axis2's design.
>
> It is a bit frustrating to see it as 'Resolved' without neither a single
> change associated to it nor does it seem the issue has been properly
> reviewed.
>
> A code review, especially regarding the use of static fields in this
> context, would do it good.
>
> Thanks,
>  Tammo
>
> PS: Sorry for the rant, besides of that, Axis is great stuff :)
>
> --
> Tammo van Lessen - http://www.taval.de
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-dev-help@axis.apache.org
>



-- 
Tammo van Lessen - http://www.taval.de

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message