axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nadir amra (Reopened) (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (AXIS2-4692) Java2WSDL not generating location HTTPS
Date Sat, 28 Jan 2012 05:25:10 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-4692?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

nadir amra reopened AXIS2-4692:
-------------------------------

      Assignee:     (was: Lahiru Gunathilake)

I am re-opening issue because the stated problem is not resolved. 

Restating the problem, there is no way to specify both http and https endpoints on the java2wsdl
command, nor is there a way for java2wsdl command to process https endpoint when passed by
itself.

There needs to be a solution other than having a user modify the axis2 java code and recompiling.
 

Since the default axis2.xml does not have https transport, we have two choices (I am assuming
that we cannot add https transport to default axis2.xml):

(1) Ignore the configuration and simply add the specified endpoint

(2) Add an option where a user can pass in a path to axis2.xml file to use. 

We also need to allow user to specify two endpoints.....


                
> Java2WSDL not generating location HTTPS
> ---------------------------------------
>
>                 Key: AXIS2-4692
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4692
>             Project: Axis2
>          Issue Type: Bug
>         Environment: OS: Debian GNU/Linux
> WSO2 WSAS v3.1.3
>            Reporter: Vitor Manuel Alves Rodrigues
>         Attachments: Entity_HTTP.wsdl, Entity_HTTPS.wsdl, services.xml
>
>
> Hi everyone,
> I have this in my build.xml, to generate my wsdl:
> ...
> <java classname="org.apache.ws.java2wsdl.Java2WSDL" fork="yes" >
>              <arg value="-l"/> 
>              <arg value="https://entitas-d.corp.turismodeportugal.pt:9443/services/Entity"
/> 
> 	     <arg value="-of"/>
>              <arg value="${wsdl.dir}/Entity.wsdl" />
> 	     <arg value="-tn"/>  
> 	     <arg value="http://entitas.turismodeportugal.pt" /> -->
>  	    <!-- <arg value="-cn" />
>              <arg value="pt.turismodeportugal.entitas.Entity" />
>       <classpath>
>        <path refid="axis.classpath"/>
>        <pathelement path="${classes.dir}"/>
>       </classpath>
>      </java> 
> ...
> For HTTP(changing the line   <arg value="https://entitas-d.corp.turismodeportugal.pt:9443/services/Entity"
/> to   <arg value="http://entitas-d.corp.turismodeportugal.pt:9763/services/Entity"
/>) it produces this in the wsdl:
> ....
>  <wsdl:service name="Entity">
>         <wsdl:port name="EntityHttpSoap11Endpoint" binding="ns:EntitySoap11Binding">
>             <soap:address location="http://entitas-d.corp.turismodeportugal.pt:9763/services/Entity"/>
>         </wsdl:port>
>         <wsdl:port name="EntityHttpSoap12Endpoint" binding="ns:EntitySoap12Binding">
>             <soap12:address location="http://entitas-d.corp.turismodeportugal.pt:9763/services/Entity"/>
>         </wsdl:port>
>         <wsdl:port name="EntityHttpEndpoint" binding="ns:EntityHttpBinding">
>             <http:address location="http://entitas-d.corp.turismodeportugal.pt:9763/services/Entity"/>
>         </wsdl:port>
>     </wsdl:service>
> ....
> For the HTTPS, it doesn't produce the Endpoints.... Any ideas? Something in the services.xml
missing? I will attach the files.....
> Help please it urgent :S

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message