axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiranya Jayathilaka <hiranya...@gmail.com>
Subject Neethi 3.0.2 Issue
Date Wed, 21 Dec 2011 16:24:03 GMT
Hi Folks,

I'm trying to get WSO2 Throttling trunk (an open source project dependent
on Neethi) working with Neethi 3.0.2. I was able to get it to work with
Neethi 3.0.0. But cannot get it to work with 3.0.1 and 3.0.2. Keep getting
the following error:

java.lang.IllegalArgumentException: {
http://www.wso2.org/products/wso2commons/throttle}ThrottleAssertion is not
a <wsp:Policy> element.
at org.apache.neethi.PolicyBuilder.getPolicyOperator(PolicyBuilder.java:177)
at org.apache.neethi.PolicyBuilder.getPolicy(PolicyBuilder.java:125)
at org.apache.neethi.PolicyEngine.getPolicy(PolicyEngine.java:113)
at
org.wso2.throttle.ThrottleFactory.createThrottle(ThrottleFactory.java:135)
at
org.wso2.throttle.ThrottleFactory.createMediatorThrottle(ThrottleFactory.java:89)

Any idea what changed in the API for this code to break?

Thanks
-- 
Hiranya Jayathilaka
Associate Technical Lead;
WSO2 Inc.;  http://wso2.org
E-mail: hiranya@wso2.com;  Mobile: +94 77 633 3491
Blog: http://techfeast-hiranya.blogspot.com

Mime
View raw message