axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amila Jayasekara <ami...@wso2.com>
Subject Re: Trouble interfacing with WCF
Date Mon, 08 Aug 2011 06:34:10 GMT
Hi Jay,

Sorry for the delay reply.

You dont need to engage rampart specifically talk to a HTTPS endpoint.
You need to make sure that relevant server certificate in your
truststore. In addition if you are using a truststore other Java
default truststore you need set trust store parameters within your
code as follows,

System.setProperty("javax.net.ssl.trustStore",
"/home/amila/development/Tools/keystore/article-transport/keys/server.jks");
System.setProperty("javax.net.ssl.trustStorePassword", "password");

Regarding sc.engageModule("addressing");, this might be due to the way
you have configured your server. According to IIS configuration you
are using "wsHttpBinding". I am not sure whether you need addressing
in "wsHttpBinding". Probably you do need addressing for
"wsHttpBinding", therefore when you engage "addressing" it started
working.

Hope this explains the situation.

Thanks
AmilaJ


On Thu, Jul 28, 2011 at 12:07 AM, Jay Sullivan <notfed@gmail.com> wrote:
> Wow!!!!!!!!!!!!!!!!!!!!!! :) .  Changing
>
>> sc.engageModule("rampart");
>
> to
>
>> sc.engageModule("addressing");
>
> Fixed both errors and now it WORKS! I can't believe it!  I had already
> become so skeptical that I didn't think it would ever work.  Now, can anyone
> explain why this worked? (and why I can't find anywhere on the web that
> someone's offered this solution?)
>
> --
> Jay Sullivan
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message