axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhinav Mishra (JIRA)" <j...@apache.org>
Subject [jira] Updated: (RAMPART-324) Caused by: org.apache.ws.security.WSSecurityException: General security error (WSEncryptBody/WSSignE nvelope: Element to encrypt/sign not found: {http://ws.apache.org/axis2}args0)
Date Tue, 01 Mar 2011 14:27:42 GMT

     [ https://issues.apache.org/jira/browse/RAMPART-324?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Abhinav Mishra updated RAMPART-324:
-----------------------------------

      Priority: Blocker  (was: Critical)
    Issue Type: Question  (was: Bug)

> Caused by: org.apache.ws.security.WSSecurityException: General security error (WSEncryptBody/WSSignE
nvelope: Element to encrypt/sign not found: {http://ws.apache.org/axis2}args0)
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: RAMPART-324
>                 URL: https://issues.apache.org/jira/browse/RAMPART-324
>             Project: Rampart
>          Issue Type: Question
>          Components: rampart-core, rampart-policy
>    Affects Versions: 1.4
>         Environment: Windows XP, Rampart 1.4,JDK1.5_06,Axis2 1.5
>            Reporter: Abhinav Mishra
>            Assignee: Thilina Buddhika
>            Priority: Blocker
>              Labels: security
>         Attachments: Client.java, Multiplication4.java, Multiplication4CallbackHandler.java,
Multiplication4Stub.java, PWCBHandler.java, PWCBHandler.java, client.jks, service.jks, services.xml
>
>   Original Estimate: 504h
>  Remaining Estimate: 504h
>
> Here I am trying to run a multiplication service in which I pass 2 parameters. In these
two parameters I am trying to encrypt and sign only single element. For this I am using <SignedElements>
and <EncryptedElements> assertions. I am calling the service using Client stub in which
the namaspace generated  is xmlns:ns1="http://ws.apache.org/axis2". I amt trying to use Xpath
for that element as <sp:XPath>/soapenv:Envelope/soapenv:Body/ns1:mul/ns1:args0</sp:XPath>
where soapenv is xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope">.
> When this got error i changed Xpath to:
> <sp:XPath>descendant::ns1:args0</sp:XPath>
>  But i am getting an error which is 
> Caused by: org.apache.ws.security.WSSecurityException: General security error (WSEncryptBody/WSSignE
nvelope: Element to encrypt/sign not found: {http://ws.apache.org/axis2}args0)
> Abhinav
> Abhinav Mishra
> Exception in thread "main" org.apache.axis2.AxisFault: Error during encryption
>         at org.apache.rampart.handler.RampartSender.invoke(RampartSender.java:70)
>         at org.apache.axis2.engine.Phase.invoke(Phase.java:318)
>         at org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:251)
>         at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:416)
>         at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:402)
>         at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java
> :229)
>         at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
>         at org.apache.ws.axis2.Multiplication4Stub.mul(Multiplication4Stub.java:187)
>         at org.apache.ws.axis2.Client.main(Client.java:38)
> Caused by: org.apache.rampart.RampartException: Error during encryption
>         at org.apache.rampart.builder.AsymmetricBindingBuilder.doSignBeforeEncrypt(AsymmetricBinding
> Builder.java:544)
>         at org.apache.rampart.builder.AsymmetricBindingBuilder.build(AsymmetricBindingBuilder.java:9
> 3)
>         at org.apache.rampart.MessageBuilder.build(MessageBuilder.java:147)
>         at org.apache.rampart.handler.RampartSender.invoke(RampartSender.java:64)
>         ... 8 more
> Caused by: org.apache.ws.security.WSSecurityException: General security error (WSEncryptBody/WSSignE
> nvelope: Element to encrypt/sign not found: {http://ws.apache.org/axis2}args0)
>         at org.apache.ws.security.message.WSSecEncrypt.doEncryption(WSSecEncrypt.java:496)
>         at org.apache.ws.security.message.WSSecEncrypt.doEncryption(WSSecEncrypt.java:454)
>         at org.apache.ws.security.message.WSSecEncrypt.encryptForInternalRef(WSSecEncrypt.java:351)
>         at org.apache.rampart.builder.AsymmetricBindingBuilder.doSignBeforeEncrypt(AsymmetricBinding
> Builder.java:530)
>         ... 11 more
> So,please help me to solve this issue.
> Here i am attaching my code and services.xml file.
> Thanks in advance!!!

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message