axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ancoron Luciferis (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-4947) [patch] OSGi imports inappropriate for common environments
Date Fri, 04 Feb 2011 04:25:22 GMT
[patch] OSGi imports inappropriate for common environments
----------------------------------------------------------

                 Key: AXIS2-4947
                 URL: https://issues.apache.org/jira/browse/AXIS2-4947
             Project: Axis2
          Issue Type: Bug
    Affects Versions: nightly
         Environment: E.g. GlassFish 3.1 / Felix 3.x / Java 6
            Reporter: Ancoron Luciferis
            Priority: Critical
             Fix For: 1.5.5


Most common environments define all package exports issued by the framework with the system
version "0.0.0".

Because Axis2 OSGi specifies the following imports with higher versions it is not possible
to use the provided OSGi bundle as is and has to be modified:

javax.ws.rs; version=1.0,
javax.activation;version="1.1",
javax.xml.stream;resolution:=optional;version="1.0"

I'll attach a patch to fix this problem.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message