axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Afkham Azeez <afk...@gmail.com>
Subject MTOM broken?
Date Tue, 04 Jan 2011 13:56:16 GMT
Is MTOM working properly in the current Axis2 trunk?

We have some services with the enableMTOM parameter set to true and when we
invoke those services using stubs generated using WSDL2Java, we get this
error on the client side. Basically, the client cannot process the response
it received.

com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '-' (code
45) in prolog; expected '<'
 at [row,col {unknown-source}]: [1,1]
at com.ctc.wstx.sr.StreamScanner.throwUnexpectedChar(StreamScanner.java:648)
at
com.ctc.wstx.sr.BasicStreamReader.nextFromProlog(BasicStreamReader.java:2047)
 at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1069)
at
org.apache.axiom.util.stax.wrapper.XMLStreamReaderWrapper.next(XMLStreamReaderWrapper.java:225)
 at
org.apache.axiom.util.stax.dialect.DisallowDoctypeDeclStreamReaderWrapper.next(DisallowDoctypeDeclStreamReaderWrapper.java:34)
at
org.apache.axiom.util.stax.wrapper.XMLStreamReaderWrapper.next(XMLStreamReaderWrapper.java:225)
 at
org.apache.axiom.om.impl.builder.StAXOMBuilder.parserNext(StAXOMBuilder.java:681)
at
org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:214)
 at
org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.getSOAPEnvelope(StAXSOAPModelBuilder.java:204)
at
org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:154)
 at
org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:140)
at org.apache.axis2.builder.SOAPBuilder.processDocument(SOAPBuilder.java:67)
 at
org.apache.axis2.transport.TransportUtils.createDocumentElement(TransportUtils.java:179)
at
org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:145)
 at
org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:108)
at
org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:67)
 at
org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:354)
at
org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:421)
 at
org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)


If enableMTOM is set to false either in the service or the relevant
operation, the invocation returns successfully.

These services & clients were working fine earlier.

Any idea what could have gone wrong?

Thanks
Azeez
*
*

Mime
View raw message