axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Eclipse versions in Axis2 trunk are not available in eclipse repository we are using
Date Tue, 26 Oct 2010 09:24:50 GMT
On Tue, Oct 26, 2010 at 11:01, Isuru Suriarachchi <isurues@gmail.com> wrote:
> Hi Andreas,
>
> On Tue, Oct 26, 2010 at 11:46 AM, Andreas Veithen
> <andreas.veithen@gmail.com> wrote:
>>
>> Actually the artifacts are still in the repository (BTW, the people
>> maintaining these repos follow a very strict policy of never removing
>> any artifacts).
>
> I checked the above repo for the dependencies used by Axis2. For example,
> org.eclipse.core.jobs 3.2.0 is not there at [2]. Am I missing something?

It is there, and it has always been there:

http://repo1.maven.org/eclipse/org/eclipse/core/org.eclipse.core.jobs/

The problem is that the artifact is located in the Eclipse repo, and
Maven suddenly thinks that it should be located in central.

>>
>> However, for some reasons, Maven attempts to resolve
>> some of the dependencies from central (and only from central). For the
>> moment I have no explanation for this. Note that this is not
>> necessarily a problem with the Eclipse repo, but could be caused by
>> artifacts added to one of the other repositories we use. The really
>> annoying thing is that the issue also occurs on the 1.5 branch, and
>> therefore probably also with the 1.5.2 sources. This means that after
>> the java.net incident, we again ended up in a situation where our
>> previous releases are no longer buildable.
>
> So one option would be to host those dependencies in the Apache maven repo
> itself.

There is no such thing as an Apache Maven repo (other than Maven
central). One option would be to change the versions of the
dependencies to versions that are available in the central repository
and eliminate the Eclipse repo configuration altogether.

> Thanks,
> ~Isuru
>
> [2] http://repo1.maven.org/maven2/org/eclipse/core/org.eclipse.core.jobs/
>
>>
>> Interestingly, when using Maven 3.0 (beta 1), the build actually
>> succeeds...
>>
>> Andreas
>>
>> On Mon, Oct 25, 2010 at 14:40, Isuru Suriarachchi <isurues@gmail.com>
>> wrote:
>> > Hi all,
>> >
>> > Our axis2-eclipse plugins use few eclipse dependencies and their current
>> > version is 3.2.0. And the eclipse maven repository we are using is [1].
>> > But
>> > version 3.2.0 of those dependencies are no longer available in [1]. So
>> > when
>> > we build axis2 with a clean repository, it breaks.
>> >
>> > So how are we going to fix this? Are there any other maven repository
>> > with
>> > eclipse libraries?
>> >
>> > Thanks,
>> > ~Isuru
>> >
>> > [1] http://repo1.maven.org/eclipse
>> >
>> > --
>> > Technical Lead,
>> > WSO2 Inc. http://wso2.org/
>> > Blog : http://isurues.wordpress.com/
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>> For additional commands, e-mail: java-dev-help@axis.apache.org
>>
>
>
>
> --
> Technical Lead,
> WSO2 Inc. http://wso2.org/
> Blog : http://isurues.wordpress.com/
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message