axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Re: [Axis2] 1.5 branch build broken
Date Wed, 23 Jun 2010 02:03:41 GMT
Hiranya Jayathilaka wrote:
>
>
> On Tue, Jun 22, 2010 at 5:43 AM, Dennis Sosnoski <dms@sosnoski.com 
> <mailto:dms@sosnoski.com>> wrote:
>
>     as usual...  :-(
>
>     Just got the source from
>     https://svn.apache.org/repos/asf/axis/axis2/java/core/branches/java/1_5/
>     (which looks to be correct for the new TLP structure), when I run
>     "mvn clean install" I get:
>
>     Missing:
>     ----------
>     1) org.apache.ws.commons.axiom:axiom-api:jar:1.2.9-SNAPSHOT
>     ...
>     2) org.apache.ws.commons.axiom:axiom-dom:jar:1.2.9-SNAPSHOT
>     ...
>     3) org.apache.ws.commons.axiom:axiom-impl:jar:1.2.9-SNAPSHOT
>
>
> Looks like the Axiom snapshots are not available in any of the maven 
> repos. You can try checking out the Axiom trunk and building it manually.
>
> Thanks,
> Hiranya

Thanks for the suggestion, Hiranya. I checked out Axiom, upgraded to a 
more recent Maven to make that build - and then had the same problem. It 
turns out Axiom is now building 1.2.10-SNAPSHOT, rather than 1.2.9. I 
changed the version referenced by the Axis2 build to 1.2.10-SNAPSHOT, 
and that got me further. Now it's the jaxws-integration tests that have 
errors, which usually seems to be the case in my build attempts.

It'd give more of an impression of quality software development if the 
Axis2 projects were at least kept in a state where they could be built. 
But I'll just ignore the rest of the code and build only the few parts I 
need for my code changes, rather than trying to actually run the full 
build and tests.

  - Dennis

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message