axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Katherine Sanders (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4691) JAX-WS module compile fails due to Java heap space error on Windows XP
Date Thu, 22 Apr 2010 20:38:51 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12859999#action_12859999
] 

Katherine Sanders commented on AXIS2-4691:
------------------------------------------

Adding fork=true to the jaxws module pom.xml fixed the first error, but then I hit the same
error in the jaxws-integration and axis2-idea-plugin modules.  I added the fork=true option
to their pom.xml files too.  However, then I got the same error in the corba module and it
didn't have a maven-compiler-plugin stanza to add the fork property to.  I tried increasing
the heap size to 2048m but that still didn't fix the problem.  To get a successful build I
had to take the corba module out of the top level pom.xml and then build it separately afterwards.

Does anyone have any ideas how to fix this more permanently?

> JAX-WS module compile fails due to Java heap space error on Windows XP
> ----------------------------------------------------------------------
>
>                 Key: AXIS2-4691
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4691
>             Project: Axis2
>          Issue Type: Bug
>          Components: jaxws
>         Environment: Apache Maven 2.0.11 (r909250; 2010-02-12 05:55:50+0000)
> Java version: 1.6.0_16
> Java home: C:\Program Files\Java\jdk1.6.0_16\jre
> Default locale: en_GB, platform encoding: Cp1252
> OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"
> Same errors occur with maven 2.2.1 and jdk 1.5.0_16
>            Reporter: Katherine Sanders
>
> The following error occurs when I do a full axis2 build on the latest revision.  The
error has been occurring since r934683 (r933791builds without errors). 
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Apache Axis2 - JAXWS
> [INFO]    task-segment: [clean, install]
> [INFO] ------------------------------------------------------------------------
> [INFO] [clean:clean]
> [INFO] Deleting directory C:\sandbox\axis2\modules\jaxws\target
> [INFO] [remote-resources:process {execution: default}]
> [INFO] [remote-resources:process {execution: legal-files}]
> [INFO] [resources:resources]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] skip non existing resourceDirectory C:\sandbox\axis2\modules\jaxws\conf
> [INFO] Copying 0 resource
> [INFO] Copying 2 resources
> [INFO] Copying 5 resources
> [INFO] Copying 5 resources
> [INFO] [compiler:compile]
> [INFO] Compiling 276 source files to C:\sandbox\axis2\modules\jaxws\target\classes
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Fatal error compiling
> Embedded error: Error while executing the compiler.
> Java heap space
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 6 minutes 54 seconds
> [INFO] Finished at: Wed Apr 21 17:10:03 BST 2010
> [INFO] Final Memory: 53M/63M
> [INFO] ------------------------------------------------------------------------

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message