axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitor Manuel Alves Rodrigues (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4650) BAD WSDL generation from Java class
Date Mon, 15 Mar 2010 10:40:27 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4650?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12845274#action_12845274
] 

Vitor Manuel Alves Rodrigues commented on AXIS2-4650:
-----------------------------------------------------

Hello Amila,


When i build using what you tould me:

[INFO] [clean:clean]
[INFO] [remote-resources:process {execution: default}]
[INFO] [remote-resources:process {execution: legal-files}]
[INFO] [resources:resources]
[INFO] Using encoding: 'UTF-8' to copy filtered resources.
[INFO] [compiler:compile]
[INFO] Compiling 9 source files to /root/axis2/modules/java2wsdl/target/classes
[INFO] [resources:testResources]
[INFO] Using encoding: 'UTF-8' to copy filtered resources.
[INFO] [compiler:testCompile]
[INFO] Not compiling test sources
[INFO] [surefire:test]
[INFO] Tests are skipped.
[INFO] [antrun:run {execution: default}]
[INFO] Executing tasks
     [echo] Generating p2n.wsdl
     [java] Exception in thread "main" java.lang.ClassNotFoundException: org.apache.axis2.description.CalculatorService
     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
     [java]     at java.security.AccessController.doPrivileged(Native Method)
     [java]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
     [java]     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
     [java]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
     [java]     at java.lang.Class.forName0(Native Method)
     [java]     at java.lang.Class.forName(Class.java:247)
     [java]     at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.<init>(DefaultSchemaGenerator.java:140)
     [java]     at org.apache.ws.java2wsdl.Java2WSDLBuilder.resolveSchemaGen(Java2WSDLBuilder.java:368)
     [java]     at org.apache.ws.java2wsdl.Java2WSDLBuilder.generateWSDL(Java2WSDLBuilder.java:211)
     [java]     at org.apache.ws.java2wsdl.Java2WSDLCodegenEngine.generate(Java2WSDLCodegenEngine.java:59)
     [java]     at org.apache.ws.java2wsdl.Java2WSDL.main(Java2WSDL.java:32)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] An Ant BuildException has occured: Java returned: 1

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 minute
[INFO] Finished at: Sun Mar 14 16:55:15 WET 2010
[INFO] Final Memory: 48M/63M
[INFO] ------------------------------------------------------------------------


I'm trying, neitherless calling java2wsdl class to test, like this:

/* In this dir i have my class Entity.class(the class i want to generate wsdl), axis2-SNAPSHOT.jar,
the unpacked jar(which creates org dir and sub-folders(i will attach the tree view in this
issue)
*/
// this is me trying to generate de wsdl, from the Java Class

/root/java2wsdl$ rm -f abc.wsdl; export JAVA_HOME=/usr/lib/jvm/java-6-sun; export AXIS2_HOME=/opt/wso2wsas;
java -cp .:$AXIS2_HOME/lib/commons-logging-1.1.1.jar:$AXIS2_HOME/repository/components/plugins/axiom-1.2.7.wso2v1.jar:$AXIS2_HOME/repository/components/plugins/neethi-2.0.4.wso2v1.jar
org.apache.ws.java2wsdl.Java2WSDL -of abc.wsdl -cn Entity

And it gaves me this error:

Exception in thread "main" java.lang.RuntimeException: org.apache.axis2.deployment.DeploymentException:
org.apache.axis2.transport.local.LocalTransportSender
        at org.apache.ws.java2wsdl.Java2WSDLBuilder.<init>(Java2WSDLBuilder.java:108)
        at org.apache.ws.java2wsdl.Java2WSDLCodegenEngine.<init>(Java2WSDLCodegenEngine.java:51)
        at org.apache.ws.java2wsdl.Java2WSDL.main(Java2WSDL.java:31)
Caused by: org.apache.axis2.deployment.DeploymentException: org.apache.axis2.transport.local.LocalTransportSender
        at org.apache.axis2.deployment.AxisConfigBuilder.processTransportSenders(AxisConfigBuilder.java:711)
        at org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:122)
        at org.apache.axis2.context.ConfigurationContextFactory.createBasicConfigurationContext(ConfigurationContextFactory.java:343)
        at org.apache.axis2.context.ConfigurationContextFactory.createDefaultConfigurationContext(ConfigurationContextFactory.java:330)
        at org.apache.ws.java2wsdl.Java2WSDLBuilder.<init>(Java2WSDLBuilder.java:101)
        ... 2 more
Caused by: java.lang.ClassNotFoundException: org.apache.axis2.transport.local.LocalTransportSender
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at org.apache.axis2.util.Loader.loadClass(Loader.java:261)
        at org.apache.axis2.deployment.AxisConfigBuilder.processTransportSenders(AxisConfigBuilder.java:686)
        ... 6 more


And thoughts, ideas?









> BAD WSDL generation from Java class
> -----------------------------------
>
>                 Key: AXIS2-4650
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4650
>             Project: Axis2
>          Issue Type: Bug
>         Environment: OS: Debian GNU/Linux
> WSO2 WSAS v3.1.3
>            Reporter: Vitor Manuel Alves Rodrigues
>         Attachments: entity.txt
>
>
> Hello everyone,
> I have this snippet from the WSDL:
> ...
> <xs:complexType name="EntityCompanyWithCountType">
>                 <xs:sequence>
>                     <xs:element minOccurs="0" name="count" nillable="true" type="xs:int"
/>
>                     <xs:element maxOccurs="unbounded" minOccurs="0" name="entity"
nillable="true" />
>                 </xs:sequence>
> </xs:complexType>
> ...
> The correct would be this:
> <xs:complexType name="EntityCompanyWithCountType">
>                 <xs:sequence>
>                     <xs:element minOccurs="0" name="count" nillable="true" type="xs:int"
/>
>                     <xs:element maxOccurs="unbounded" minOccurs="0" name="entity"
type="ax2329:EntityCompanyType" nillable="true" />
>                 </xs:sequence>
> </xs:complexType>
> I have this in Java:
> public class Entity {
> ...
> /*Inner class*/
>        public class EntityCompanyWithContactType {
>         private EntityCompanyType entity;
>         private DigitalAddress.DigitalAddressType[] digital_address;
>         private PhoneNumber.PhoneNumberType[] phone_number;
>         private PostalAddress.PostalAddressType[] postal_address;
>         private PostalAddress.PostalAddressPhoneNumberType[] postal_address__phone_number;
>             /**
>          * The default constructor.
>          */
>         public EntityCompanyWithContactType(){}
>         /**
>          * The constructor with all the input for one record.
>          * @param entity value;
>          * @param digital_address list value;
>          * @param phone_number list value;
>          * @param postal_address list value;
>          * @param postal_address__phone_number list value;
>          */
>         public EntityCompanyWithContactType(EntityCompanyType entity, DigitalAddress.DigitalAddressType[]
digital_address, PhoneNumber.PhoneNumberType[] phone_number, PostalAddress.PostalAddressType[]
postal_address, PostalAddress.PostalAddressPhoneNumberType[] postal_address__phone_number)
{ .. }
>  
> .....
> }
> I'm using "ant install" -> <echo> - install: build of AAR and deploy into WSAS.
Also generates API documentation.</echo>
> My build.xml  :
> ..
> <target name="install"
>           depends="build-service,doc"
>           description="Installs the service package AAR into the Web service server repository.">
>     <echo message="Copying the created AAR files into the repository..."/>
>     <copy toDir="${repository.dir}/${services.dir}">
>       <fileset dir="${services.dir}">
>         <include name="**/*.aar"/>
>       </fileset>
>     </copy>
>   </target>
> ...
> What am i doing wrong? Help. :(
> For more info, please please contact me :)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message