axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amila Chinthaka Suriarachchi (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-4648) HTTPS Only Transport does not work
Date Sun, 07 Mar 2010 10:12:27 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-4648?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Amila Chinthaka Suriarachchi resolved AXIS2-4648.
-------------------------------------------------

    Resolution: Fixed

fixed with the revision 919960.

please have a look at from a build from trunk.

> HTTPS Only Transport does not work
> ----------------------------------
>
>                 Key: AXIS2-4648
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4648
>             Project: Axis2
>          Issue Type: Bug
>          Components: transports
>    Affects Versions: 1.5.1
>         Environment: Solaris, apache tomcat 6.0.24 
>            Reporter: Vish Shah
>            Priority: Critical
>
> Hi,
> It seems HTTPS only transport does not work with 2.1.5.1. The following code executes
and expects the HTTP transport definition in Axis2.xml file.
>  
> TransportOutDescription transportOut = msgContext.getConfigurationContext().
>                     getAxisConfiguration().getTransportOut(Constants.TRANSPORT_HTTP);
>   
> Steps to reproduce 
> 1. only keep https definition in axis2.xml and remove http definition.
> 2. run any axis2 service. Result would be a Null pointer exception
> In my Axis2.xml configuration, i removed the HTTP (<transportSender name="http") transport
sender and am only having the "https" transport sender . I see that the request comes in fine
into the service, however i get a NullPointer at the time the response is to be sent..Why
is that?  What if i just want to use HTTPS ?
> java.lang.NullPointerException
>         at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:170)
>         at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:435)
>         at org.apache.axis2.receivers.AbstractInOutMessageReceiver.invokeBusinessLogic(AbstractInOutMessageReceiver.java:43)
>         at org.apache.axis2.receivers.AbstractMessageReceiver.receive(AbstractMessageReceiver.java:114)
>         at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:173)
>         at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:167)
>         at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:142)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
>  
>      <transportSender name="local"
>                      class="org.apache.axis2.transport.local.LocalTransportSender"/>
>     <transportSender name="https"
>                      class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">
>         <parameter name="PROTOCOL">HTTP/1.1</parameter>
>         <parameter name="Transfer-Encoding">chunked</parameter>
>     </transportSender> 
> knowing that 1.6 does not happen soon, it would be great if there could be a patch provided
to resolve this issue, it would not be easy for lot of them to upgrade versions very frequently.
can Axis2 commiter please provide a patch ASAP to resolve this ?
> Thanks,
> Vish

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message