axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (AXIS2-4596) Client unable to turn on addressing with UsingAddressing in the WSDL
Date Tue, 02 Feb 2010 21:36:18 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-4596?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Veithen reopened AXIS2-4596:
------------------------------------


Kathrine,
Brian,

I just updated my working copy with the change and it causes a build failure:

testWithoutUsingAddressing(org.apache.axis2.jaxws.addressing.UsingAddressingTests)  Time elapsed:
0.084 sec  <<< ERROR!
javax.xml.ws.WebServiceException: The following WSDL exception occurred: WSDLException: faultCode=WSDL4JWrapper
: : javax.wsdl.WSDLException: WSDLException: faultCode=WSDL4JWrapper : : java.net.UnknownHostException:
Users
        at org.apache.axis2.jaxws.ExceptionFactory.createWebServiceException(ExceptionFactory.java:173)
        at org.apache.axis2.jaxws.ExceptionFactory.makeWebServiceException(ExceptionFactory.java:70)
        at org.apache.axis2.jaxws.description.impl.ServiceDescriptionImpl.setupWsdlDefinition(ServiceDescriptionImpl.java:1082)
        at org.apache.axis2.jaxws.description.impl.ServiceDescriptionImpl.<init>(ServiceDescriptionImpl.java:237)
        at org.apache.axis2.jaxws.description.impl.ServiceDescriptionImpl.<init>(ServiceDescriptionImpl.java:160)
        at org.apache.axis2.jaxws.description.impl.DescriptionFactoryImpl.createServiceDescription(DescriptionFactoryImpl.java:133)
        at org.apache.axis2.jaxws.description.impl.DescriptionFactoryImpl.createServiceDescription(DescriptionFactoryImpl.java:79)
        at org.apache.axis2.jaxws.description.DescriptionFactory.createServiceDescription(DescriptionFactory.java:78)
        at org.apache.axis2.jaxws.spi.ServiceDelegate.<init>(ServiceDelegate.java:213)
        at org.apache.axis2.jaxws.spi.Provider.createServiceDelegate(Provider.java:59)
        at javax.xml.ws.Service.<init>(Service.java:36)
        at javax.xml.ws.Service.create(Service.java:116)
        at org.apache.axis2.jaxws.addressing.UsingAddressingTests.testWithoutUsingAddressing(UsingAddressingTests.java:81)
...

Note that "Users" is actually the first component of the path to my working copy. I think
the problem is due to URL manipulations that are not portable (I'm running the build on Mac
OS X).

I will do an attempt to fix this issue.

> Client unable to turn on addressing with UsingAddressing in the WSDL
> --------------------------------------------------------------------
>
>                 Key: AXIS2-4596
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4596
>             Project: Axis2
>          Issue Type: Bug
>          Components: jaxws
>            Reporter: Katherine Sanders
>            Assignee: Brian DePradine
>             Fix For: 1.6
>
>         Attachments: AXIS2-4596.patch
>
>
> Revision 702224 defaulted DISABLE_ADDRESSING_FOR_OUT_MESSAGES to true in BindingProvider,
however it didn't add any code to turn addressing on if <wsaw:usingAddressing /> is
present in the WSDL.  This means that addressing is always off on the client unless AddressingFeature
is used to turn it on, and that's only available in JAX-WS 2.1 clients.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message