axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruwan Linton (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (AXIS2-4304) Improve the ListenerManager startup behavior
Date Sat, 14 Nov 2009 12:42:39 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12777908#action_12777908
] 

Ruwan Linton edited comment on AXIS2-4304 at 11/14/09 12:41 PM:
----------------------------------------------------------------

Andreas, It cannot be a regression caused by the patch, please see my comments on the issue
AXIS2-4552 [1], rather it should be a cause of the wrong usage of the listener manager API.

[1] - https://issues.apache.org/jira/browse/AXIS2-4552?focusedCommentId=12777907&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_12777907

      was (Author: ruwan):
    Andreas, It cannot be a regression caused by the patch, please see my comments on the
issue AXIS2-4552, rather it should be a cause of the wrong usage of the listener manager API.
  
> Improve the ListenerManager startup behavior
> --------------------------------------------
>
>                 Key: AXIS2-4304
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4304
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Improvement
>          Components: kernel
>    Affects Versions: 1.5, nightly
>         Environment: all env
>            Reporter: Ruwan Linton
>             Fix For: 1.5, nightly
>
>         Attachments: listener-manager.patch
>
>
> ListenerManager should initialize all the listeners while initializing the listener manager,
and starting of the ListenerManager should start the listeners.
> Further, for synapse requirements we need to get rid of the shutdown hook and there has
to be an option to not to set the shutdown hook while starting the listener manager.
> this is required in the 1.5 release because synapse 1.3 is going to depend on the 1.5
release of axis2.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message