axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Geelen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4471) WSDL sorking in 1.4.1, don't Work in 1.5
Date Thu, 19 Nov 2009 10:07:41 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4471?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12779912#action_12779912
] 

Stefan Geelen commented on AXIS2-4471:
--------------------------------------

Hi,

we are having exactly the same problem. 

We are trtying to upgrade from Axis2/Java 1.4.1 + Rampart and this is the last issue we have.

This is blocking for us.

Will this be addressed in 1.6 (or sooner ) ?


> WSDL sorking in 1.4.1, don't Work in 1.5
> ----------------------------------------
>
>                 Key: AXIS2-4471
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4471
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.5
>         Environment: Windows, Axis2 1.5 War deployed in JBoss 4.2.1
>            Reporter: Carles Royan
>         Attachments: HcccPrimariaService.wsdl
>
>
> I have a WSDL that Works great in axis2 1.4.1. When I upgraded to axis2 1.5, when my
service is called, the parameters are empty, although I have set the values in the client.
SOAPUI can parse and generate OK the client from WSDL, but when I call a method of my WS,
the method receives NULL values in the parameters.
> Moreover, if I delete my WSDL of my service and let axis2 generate WSDL in fly, then
it runs well.
> So, I can't understan't that a working WSDL don't Work in a new version of axis. I can't
take the WSDL generated in fly cause it isn't enough accurate (optionals elements, attributes
belonging to "anyType" and so on).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message