axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ostap (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4518) ClassNotFoundException while parsing org/apache/axis2/deployment/axis2_default.xml
Date Tue, 06 Oct 2009 19:07:31 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4518?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12762740#action_12762740
] 

Ostap commented on AXIS2-4518:
------------------------------

you have in axis2-kernel at least unresolved dependencies to axis2-transport-http and axis2-transport-local
packages:

    <dependency>
      <groupId>org.apache.axis2</groupId>
      <artifactId>axis2-transport-local</artifactId>
      <version>1.5</version>
      <type>bundle</type>
    </dependency>
    <dependency>
      <groupId>org.apache.axis2</groupId>
      <artifactId>axis2-transport-http</artifactId>
      <version>1.5</version>
      <type>bundle</type>
    </dependency>



> ClassNotFoundException while parsing org/apache/axis2/deployment/axis2_default.xml
> ----------------------------------------------------------------------------------
>
>                 Key: AXIS2-4518
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4518
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: deployment, kernel, transports
>    Affects Versions: 1.5
>         Environment: java 1.5.0_11, axis-kernel v 1.5 and dependencies are loaded from
maven Repository
>            Reporter: Ostap
>
> I use Axis client generated by XMLBeans and call an default constructor. (configurationContext==null,
axis2.xml not defined etc.) 
> Generated Stub populates default AxisService and makes an attempt to create an ServiceClient:
>         _serviceClient = new org.apache.axis2.client.ServiceClient(configurationContext,_service);
> it loads org/apache/axis2/deployment/axis2_default.xml.
> we can find there:
> ...
>     <!-- ================================================= -->
>     <!-- Transport Outs -->
>     <!-- ================================================= -->
>     <transportSender name="local"
>                      class="org.apache.axis2.transport.local.LocalTransportSender"/>
>     <transportSender name="http"
>                      class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">
>         <parameter name="PROTOCOL">HTTP/1.1</parameter>
>         <parameter name="Transfer-Encoding">chunked</parameter>
>     </transportSender>
>     <transportSender name="https"
>                      class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">
>         <parameter name="PROTOCOL">HTTP/1.1</parameter>
>         <parameter name="Transfer-Encoding">chunked</parameter>
>     </transportSender>
> ..
> Local TransportSender, CommonsHTTPTransportSender and CommonsHTTPTransportSender cannot
be found in classpath and we get ClassNotFoundException in org.apache.axis2.deployment.AxisConfigBuilder#processTransportSenders(Iterator
trs_senders) line 669:
>                 String clasName = trsClas.getAttributeValue();
>                 Class sender;
>                 try {
>                     sender = Loader.loadClass(clasName); // line 669

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message