axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-4420) axis2.xml seems to need soapMonitor enabled in it inorder to work
Date Sun, 16 Aug 2009 20:13:15 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-4420?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Veithen resolved AXIS2-4420.
------------------------------------

    Resolution: Incomplete

Marked this issue as incomplete because of lack of feedback from reporter.

> axis2.xml seems to need soapMonitor enabled in it inorder to work
> -----------------------------------------------------------------
>
>                 Key: AXIS2-4420
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4420
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: adb, codegen, wsdl
>         Environment: Eclipse 3.4.2, Tomcat 5.5, Axis2 1.4.1, JSP client
>            Reporter: Ramya
>   Original Estimate: 0.83h
>  Remaining Estimate: 0.83h
>
> I have been getting a parsing exception (WStxException-) when running a JSP client against
the axis2 web service that is also deployed on the same server.
> After much investigation and finding that the same client and server works like a charm
on another machine, we suspected that there must be something different in the axis2 environment
(axis2 web application directory). Hence we adopted the approach of deleting the existing
axis2 directory under tomcat, copying it from the machine where every thing works and step
by step replace one sub folders content at a time and running the client to see at which point
does it break so that we can reproduce the error.
> So, with this approach we observed that the issue seems to be in axis2.xml file. The
only difference between the two versions is that in one the soapMonitor entry <module ref="soapmonitor"/>
is enabled whereas in the other it is either commented or not there (either way it complains!).
> It is hard to believe that SOAP monitor needs to be enabled inorder for an axis2 web
service to work!
> Could somebody shed some light on this issue - is there something that we may have missed
or not doing correctly.
> Your help is highly appreciated!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message