axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chinmoy Chakraborty <cch...@gmail.com>
Subject Re: Please help me to debug RAMPART issue
Date Fri, 31 Jul 2009 12:43:55 GMT
Hi,

I noticed following property was not set while sending the message back:

179781 DEBUG [http8080-Processor24]
org.apache.axis2.context.AbstractContext     -  Property set on object
org.apache.axis2.context.MessageContext@12f0ce9
179781 DEBUG [http8080-Processor24]
org.apache.axis2.context.AbstractContext     -   Key =messageType
179781 DEBUG [http8080-Processor24]
org.apache.axis2.context.AbstractContext     -   Value =text/xml
179781 DEBUG [http8080-Processor24]
org.apache.axis2.context.AbstractContext     -   Value Class =
java.lang.String
179781 DEBUG [http8080-Processor24]
org.apache.axis2.context.AbstractContext     -   Value Classloader = null

and then it produces following error:

[http8080-Processor21] org.apache.axis2.transport.TransportUtils     - Could
not find a Builder for type (text/html).  Using SOAP.
194422 DEBUG [http8080-Processor21]

httpclient.wire.content     - << "<html><head><title>Apache Tomcat/5.0.19
-
Error report</title><style><!--H1
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;}
H2
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;}
H3
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;}
BODY
{font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;}
P
{font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A
{color : black;}A.name {color : black;}HR {color : #525D76;}--></style>
</head><body><h1>HTTP Status 500 - </h1><HR size="1" noshade><p><b>type</b>
Status report</p><p><b>message</b> <u></u></p><p><b>description</b>
<u>The
server encountered an internal error () that prevented it from fulfilling
this request.</u></p><HR size="1" noshade><h3>Apache
Tomcat/5.0.19</h3></body></html>"
194422

DEBUG [http8080-Processor21]    org.apache.axiom.om.util.StAXUtils     -
XMLStreamReader is com.ctc.wstx.sr.ValidatingStreamReader
194422 INFO  [http8080-Processor21]
org.apache.axis2.builder.BuilderUtil     - OMException in getSOAPBuilder


Chinmoy






On Fri, Jul 31, 2009 at 2:59 PM, Chinmoy Chakraborty <cchinu@gmail.com>wrote:

> Hi,
>
> I turned on DEBUG and please find attached rampart_debug.log file. Does
> 'WSDoAllReceiver' process faults if any while invoking the business logic? I
> found following commented line at line no. 161 of WSDoAllReceiver.java src:
>
> ...............
> // Do not process faults
>         SOAPConstants soapConstants = WSSecurityUtil.getSOAPConstants(doc
>                 .getDocumentElement());
>         if (WSSecurityUtil.findElement(doc.getDocumentElement(), "Fault",
>                 soapConstants.getEnvelopeURI()) != null) {
>             return;
>         }
> ......................
>
> In line 8254 it throws the exception from the service (in the log file the
> service name is ABS) method. In line 8381 it shows :
>
> isReplyRedirected: FaultTo is null. Returning isReplyRedirected
> 194047 DEBUG [http8080-Processor24]
> org.apache.axis2.addressing.AddressingHelper     - [MessageContext:
> logID=urn:uuid:B669EB542CF5BAEF9D1249024862072] isReplyRedirected: ReplyTo
> is null. Returning false
>
> Is this the reason of not sending fault SOAP to the client if WSSecurity is
> on and use parameter based WS-Security?
>
> Chinmoy
>
>
>

Mime
View raw message