axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From frenchStudent <halem.bouh...@gmail.com>
Subject Manual deploiement with AXIS
Date Thu, 23 Jul 2009 08:55:19 GMT

Hello,

I have the following error message with this commande, I don't understand
why.

My OS is windows XP.

The commande :

C:\Program Files\Apache Software Foundation\Tomcat
6.0\webapps\axis\WEB-INF\classes>java -classpath ../lib/*.jar
org.apache.axis.client.AdminClient deploye.wsdd


The exception :

Exception in thread "main" java.lang.NoClassDefFoundError: ///lib/axis/jar
Caused by: java.lang.ClassNotFoundException: ...lib.axis.jar
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Error: Could not find the main class.
Error: A JNI error has occurred, please check your installation and try
again


NOTE 1 : Nevertheless, I define my classpath, like that :

C:\Program Files\Apache Software Foundation\Tomcat 6.0\lib\*.jar;
C:\Program Files\axis-bin-1_4\axis-1_4\lib\*.jar;

Could you correct me if I have something wrong in my classpath please.

Thank you in advance.


Best regards.





-- 
View this message in context: http://www.nabble.com/Manual-deploiement-with-AXIS-tp24621787p24621787.html
Sent from the Axis - Dev mailing list archive at Nabble.com.


Mime
View raw message