axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Detelin Yordanov (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-4445) NPE in DefaultSchemaGenerator when generating a wrapped array schema for an inner class
Date Tue, 28 Jul 2009 09:51:14 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-4445?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Detelin Yordanov updated AXIS2-4445:
------------------------------------

    Attachment:     (was: DefaultObjectSupplier.diff)

> NPE in DefaultSchemaGenerator when generating a wrapped array schema for an inner class
> ---------------------------------------------------------------------------------------
>
>                 Key: AXIS2-4445
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4445
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Sub-task
>          Components: kernel
>    Affects Versions: 1.5
>            Reporter: Detelin Yordanov
>         Attachments: DefaultSchemaGenerator.diff, WrappedArrayInnerClassService.aar
>
>
> When generating the schema for a class'  field which is an inner class, with the wrapped
array support turned on, a NPE gets thrown:
> Caused by: java.lang.NullPointerException
>         at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.generateSchemaforFieldsandProperties(DefaultSchemaGenerator.java:703)
>         at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.generateSchema(DefaultSchemaGenerator.java:555)
>         at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.generateSchemaForType(DefaultSchemaGenerator.java:862)
>         at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.processMethods(DefaultSchemaGenerator.java:334)
>         at org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator.generateSchema(DefaultSchemaGenerator.java:252)
>         at org.apache.axis2.deployment.util.Utils.fillAxisService(Utils.java:514)
>         at org.apache.axis2.deployment.ServiceBuilder.populateService(ServiceBuilder.java:386)
> Reason seems to be that the type table is searched for a complex type e.g. Data$Number,
while it should be Data_Number (replacing the dollar character with an underscore).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message