axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vijay Pandey (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-4258) Modules not getting loaded from classpath in websphere 6.1
Date Thu, 26 Feb 2009 23:05:01 GMT
Modules not getting loaded from classpath in websphere 6.1
----------------------------------------------------------

                 Key: AXIS2-4258
                 URL: https://issues.apache.org/jira/browse/AXIS2-4258
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: deployment
    Affects Versions: 1.4.1
         Environment: JDK 5 , WebSphere application server 6.1
            Reporter: Vijay Pandey


I tried to deploy the axis2  ver 1.4.1 in websphere 6.1 with jdk 1.5 and wanted to load the
modules from the classpath., which did not work. In websphere a jar URL will be starting with
"wsjar" instead of  "jar" for eg.  the addressing module xml file came up like wsjar:file:/opt/IBM/WebSphere/xyz/xyz.ear/addressing-1.4.1.jar!/META-NNF/module.xml.

To overcome this issue in the class org.apache.axis2.deployment.RepositoryListener, method
name "loadClassPathModules()", i changed its implementation to also look for "wsjar" instead
of  just "jar"  and "file". Also since the "wsjar" is not actually an instance of  "java.net.JarURLConnection",
we can't use directly this way of getting the URL of the jar
((java.net.JarURLConnection)url.openConnection()).getJarFileURL();

One more "else if" clause was added for "wsjar" and its file name was fetched directly by
doing

else if (fileName.startsWith("wsjar")) {
    fileName =fileName.substring("wsjar:".length());
    fileName =fileName.substring(0, fileName.lastIndexOf("!/META-INF/module.xml"));
}

Thanks
Vijay



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message