axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "keith chapman" <keithgchap...@gmail.com>
Subject Re: [Axis2] Build Failures in the trunk
Date Sun, 14 Dec 2008 13:07:07 GMT
I reverted my initial commit that caused the build break this afternoon. The
build ran without fail after that.

Thanks,
Keith.

On Sun, Dec 14, 2008 at 6:24 PM, Andreas Veithen
<andreas.veithen@gmail.com>wrote:

> I see a different build failure which is caused by
> DispatchXMessageSourceTests (jaxws-integration). The failing test case
> was introduced recently (r722635) by Jarek. When I revert this change
> locally, jaxws-integration builds fine again.
>
> I also noticed that the following artifact is not (or no longer)
> available from the repositories used in the Maven build:
> com.intellij:openapi:jar:5.0. This causes a build failure in
> axis2-idea-plugin.
>
> Andreas
>
> On Fri, Dec 12, 2008 at 19:17, Deepal jayasinghe <deepalk@gmail.com>
> wrote:
> >
> >> Are org.tempuri.complex.ComplexDataTypesTest,
> >> org.tempuri.BaseDataTypesTest. and
> >> org.apache.axis2.deployment.WSDL11ToAxisServiceBuilderTest failing for
> >> you? If so, that seems to be caused by r724737 and I've mentioned this
> >> to Keith a few days ago.
> >>
> > Yes those are the test cases which are failing for me, Keith do you have
> > any idea why that happen.
> >
> > Guys, please do not commit to the trunk when there is a build failures,
> > then it become very difficult to fix the initial issue.
> >
> > Keith if the temporal solution to this issue is reverting your commit,
> > please do so.
> >
> > Thank you!
> > Deepal
> >
> >
> >> Jarek
> >>
> >> On Fri, Dec 12, 2008 at 11:36 AM, Deepal jayasinghe <deepalk@gmail.com>
> wrote:
> >>
> >>> Hi Devs,
> >>>
> >>> Seems like someone has commit changes without running the build. So
> >>> whoever broke the build, please double check your changes and PLEASE
> try
> >>> fix the build. As I can see there a number of test failures in
> >>> integration module.
> >>>
> >>> I guess that may be due to some changes happen in XMLSchema, but I am
> >>> not sure.
> >>>
> >>> Please run the build before you do any code commit :)
> >>>
> >>> Thank you!
> >>> Deepal
> >>>
> >>> --
> >>> Thank you!
> >>>
> >>>
> >>> http://blogs.deepal.org
> >>>
> >>>
> >>>
> >>
> >>
> >
> >
> > --
> > Thank you!
> >
> >
> > http://blogs.deepal.org
> >
> >
>



-- 
Keith Chapman
Senior Software Engineer
WSO2 Inc.
Oxygenating the Web Service Platform.
http://wso2.org/

blog: http://www.keith-chapman.org

Mime
View raw message